This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 699026 - KDE menu corruption with Sandy Bridge integrated graphics
KDE menu corruption with Sandy Bridge integrated graphics
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
15
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: HardwareEnablement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-22 13:16 EDT by Nick Soracco
Modified: 2011-05-19 00:54 EDT (History)
3 users (show)

See Also:
Fixed In Version: xorg-x11-drv-intel-2.15.0-3.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 00:54:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 750964 None None None Never

  None (edit)
Description Nick Soracco 2011-04-22 13:16:12 EDT
Description of problem: All pull-down menus in KDE 4.6 are distorted and unreadable.  (the rest of the window treatments appear OK)  This is only a problem with Intel Sandy Bridge integrated graphics.

The machine in question is a relatively new Dell Latitude E6420


Version-Release number of selected component (if applicable): 2.14.0-4


How reproducible: Always


Steps to Reproduce:
1. Boot into x86_64 KDE Live CD
2. Open Konsole or any other KDE program
3. Pull down the file or edit (or other) menu
  
Actual results: Menu items are unreadable and their backgrounds are completely distored.

Expected results: normal menus.

Additional info: This bug was also encountered by the Ubuntu team (see: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/750964 ) and there appears to be a patch contributed that reportedly fixes the issue.

Intel also released 2.15.0 last week, but I haven't had a chance to patch that into the SRPM to see if it fixes it also.

Screenshots forthcoming.
Comment 1 Nick Soracco 2011-04-22 13:18:09 EDT
I haven't tried the 32 bit live CD image yet, so I'm not sure if this bug is architecture specific or not.  If you want, I will do so.
Comment 2 Nick Soracco 2011-04-22 13:27:38 EDT
Since this was a live image, I didn't even check yum update yet.  There's an update to this driver.  I'll test it shortly.

Output from lscpi -vnn

00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
        Subsystem: Dell Device [1028:0493]
        Flags: bus master, fast devsel, latency 0, IRQ 48
        Memory at e1400000 (64-bit, non-prefetchable) [size=4M]
        Memory at d0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 4000 [size=64]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: <access denied>
        Kernel modules: i915

Relevant bits from dmidecode:

Handle 0x0001, DMI type 1, 27 bytes
System Information
        Manufacturer: Dell Inc.
        Product Name: Latitude E6420
        Version: 01



Output from cat /proc/cpuinfo (multiply by 4)

processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 42
model name      : Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz
stepping        : 7
cpu MHz         : 800.000
cache size      : 3072 KB
physical id     : 0
siblings        : 4
core id         : 0
cpu cores       : 2
apicid          : 0
initial apicid  : 0
fpu             : yes
fpu_exception   : yes
cpuid level     : 13
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 x2apic popcnt aes xsave avx lahf_lm ida arat tpr_shadow vnmi flexpriority ept vpid
bogomips        : 4989.27
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:
Comment 3 Nick Soracco 2011-04-22 19:07:44 EDT
Installed the x86_64 version of the F15 beta to disk, yum updated the relevant libdrm, mesa-* and xorg-* packages.  Rebooted, and problem still exists. 

Tried the work-around suggested in the Ubuntu bug in addition to installing 2.14.0-5 and that does mitigate the problem.  Though you can see the extra repaint needed to keep the menu from corrupting.

Next step is for me to try 2.15.0
Comment 4 Nick Soracco 2011-04-22 19:26:58 EDT
Updated to 2.15.0 and removed the xorg.conf, and the problem disappeared completely, with no obvious repaint or other performance issues.

Fixed SRPM: http://www.deepgroove.org/rpm/xorg-x11-drv-intel-2.15.0-1.fc15.src.rpm
Comment 5 Nick Soracco 2011-04-22 19:39:04 EDT
p.s.: I didn't correctly update %changelog in the spec for that srpm, sorry!
Comment 6 Fedora Update System 2011-05-09 14:44:13 EDT
xorg-x11-drv-intel-2.15.0-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/xorg-x11-drv-intel-2.15.0-3.fc15
Comment 7 Fedora Update System 2011-05-09 18:38:11 EDT
Package xorg-x11-drv-intel-2.15.0-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-drv-intel-2.15.0-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/xorg-x11-drv-intel-2.15.0-3.fc15
then log in and leave karma (feedback).
Comment 8 Nick Soracco 2011-05-13 13:39:36 EDT
New driver package looks good here.  Feel free to close this out!
Comment 9 Fedora Update System 2011-05-19 00:54:11 EDT
xorg-x11-drv-intel-2.15.0-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.