Bug 69918 - infinite loop in snmpd on snmpwalk localhost public system
infinite loop in snmpd on snmpwalk localhost public system
Status: CLOSED DUPLICATE of bug 60161
Product: Red Hat Linux
Classification: Retired
Component: ucd-snmp (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-26 08:26 EDT by Chris Miles
Modified: 2015-03-04 20:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-26 08:31:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log file extract from snmp -D (23.40 KB, text/plain)
2002-07-26 08:31 EDT, Chris Miles
no flags Details

  None (edit)
Description Chris Miles 2002-07-26 08:26:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)

Description of problem:
On a clean install (both 7.0 and (another system) 7.3 updated with up2date) and 
no configuration changes starting the snmpd with /etc/init.d/snmpd start then 
running snmpwalk localhost public system results in output that stops after

system.sysORTable.sysOREntry.sysORUpTime.8 = Timeticks: (16) 0:00:00.16
system.sysORTable.sysOREntry.sysORUpTime.9 = Timeticks: (16) 0:00:00.16
Timeout: No Response from localhost

and the snmpd is found to be consuming lots of CPU time. The deamon must be 
restarted in order to get any further snmpwalk responses.
The machines tested run as firewalls with two network cards.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install ucd-snmp and ucd-snmp-utils
2.start snmpd with /etc/init.d/snmpd start
3.snmpwalk localhost public system
	

Actual Results:  Output stops after
system.sysORTable.sysOREntry.sysORUpTime.8 = Timeticks: (16) 0:00:00.16
system.sysORTable.sysOREntry.sysORUpTime.9 = Timeticks: (16) 0:00:00.16
Timeout: No Response from localhost
The snmpd is found to be consuming lots of CPU time. The deamon must be 
restarted in order to get any further snmpwalk responses.


Expected Results:  The 'system' OID tree should have been reported and the CPU 
demand released. Further requests should have been honoured by the deamon.

Additional info:

I have reported the local machine here. I have also installed 7.3 (updated with 
up2date) and get the same results on a similar firewall at a remote location.
Both machines run as firewalls with two network cards.
Otherwise they seem to be quite normal!
I have run snmpd -D. I stopped the process when the log file had reached 
320,000 lines.
Comment 1 Chris Miles 2002-07-26 08:31:05 EDT
Created attachment 67184 [details]
Log file extract from snmp -D
Comment 2 Phil Knirsch 2002-08-07 10:58:27 EDT

*** This bug has been marked as a duplicate of 60161 ***

Note You need to log in before you can comment on or make changes to this bug.