Bug 699183 - Firefox checking for British spelling instead of US
Summary: Firefox checking for British spelling instead of US
Status: CLOSED DUPLICATE of bug 439598
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox   
(Show other bugs)
Version: 14
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-24 01:16 UTC by Aram Agajanian
Modified: 2018-04-11 14:28 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-10 19:47:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Aram Agajanian 2011-04-24 01:16:15 UTC
Description of problem:
The spell check in Firefox is checking for British spelling instead of US spelling.

Version-Release number of selected component (if applicable):
firefox-3.6.16-1.fc14.x86_64

How reproducible:
Happens every time.

Steps to Reproduce:
1.  Start Firefox
2.  Go to a page with a text input field.
3.  Type the word "center" in the text input field.
  
Actual results:
Firefox indicates that the word is misspelled.

Expected results:
Firefox should not indicate that the word is misspelled.

Additional info:
The output of the command "echo $LANG" is 
LANG=en_US.utf8

Comment 1 Matěj Cepl 2011-05-10 19:21:56 UTC
Are you sure it is not something in your profile configuration? Are you able to reproduce the issue, when you create new profile (run firefox -no-remote -P on the command line to get into Profile Manager dialog to create a new one)?

Also what is the output of this command?

grep -H spellchecker .mozilla/firefox/*/prefs.js

Thank you in advance for any reply

Comment 2 Christopher Aillon 2011-05-10 19:47:35 UTC

*** This bug has been marked as a duplicate of bug 439598 ***

Comment 3 Aram Agajanian 2011-05-11 03:40:57 UTC
I am able to reproduce the issue when using a newly created profile.

The output of the command is

.mozilla/firefox/bz6ymybc.default/prefs.js:user_pref("spellchecker.dictionary", "en_ZW");

The output of the command for the newly created profile is:

.mozilla/firefox/lk235602.Default User/prefs.js:user_pref("spellchecker.dictionary", "en_HK");

If I edit prefs.js and change the value of spellchecker.dictionary to en_US, the problem seems to be resolved.


Note You need to log in before you can comment on or make changes to this bug.