Bug 699190 - Network: HTTP proxy environment variable not being set
Network: HTTP proxy environment variable not being set
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
15
Unspecified Linux
high Severity high
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-23 23:12 EDT by Artemy Kapitula, RCNTEC Ltd
Modified: 2012-07-10 13:37 EDT (History)
12 users (show)

See Also:
Fixed In Version: 3.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-10 13:37:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fedora package (2.82 KB, patch)
2011-06-06 11:56 EDT, Dan Winship
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 651778 None None None Never

  None (edit)
Description Artemy Kapitula, RCNTEC Ltd 2011-04-23 23:12:25 EDT
Description of problem:
Network proxy settings that has been set through Controk center -> Network has no effect, proxy configuration is inadequate.

Version-Release number of selected component (if applicable):
Fedora 15

How reproducible:
Setup proxy server in Network setting. These settings should be exported in all new applications via HTTP_PROXY, HTTPS_PROXY, FTP_PROXY, NO_PROXY and other env variables.

Steps to Reproduce:
Set proxy server address and port, then run terminal application

Actual results:
No ***_proxy variables set.

Expected results:
Environment variables HTTP_PROXY, HTTPS_PROXY, FTP_PROXY, SOCKS_PROXY and other should be set like it was in GNOME 2

Additional info:
These settings affects a large number of applications - Firefox, Epiphany, Pidgin, Midori, Chrome, yum, wget, links and other. While traveling into several corporate networks with a laptop, user will be annoyed if he will need to set proxy for each application on per-application basis.
Comment 1 Dan Winship 2011-04-28 12:07:37 EDT
this is fixed in gnome-terminal 3.0.1, which should be arriving in updates soon
Comment 2 Vitor Sanches 2011-05-03 08:08:02 EDT
I have the gnome-terminal indicated as shown below, but still the problem with the proxy.
[vitor.sanches bh20c @ ~] $ rpm-qa | grep gnome-terminal
gnome-terminal-3.0.1-1.fc15.i686
[vitor.sanches bh20c @ ~] $

I checked the terminal settings, and they are configured as follows:
[vitor.sanches bh20c @ ~] $ export | grep-i proxy
declare-x FTP_PROXY = "http://http://192.168.0.2:3128/"
declare-x https_proxy = "http://http://192.168.0.2:3128/"
declare-x NO_PROXY = "localhost, 127.0.0.0 / 8"
declare-x ftp_proxy = "http://http://192.168.0.2:3128/"
declare-x https_proxy = "http://http://192.168.0.2:3128/"
declare-x no_proxy = "localhost, 127.0.0.0 / 8"
[vitor.sanches bh20c @ ~] $

The settings appear to be wrong because they have 2 times "http://".

I believe that beyond these settings, requiring the setting http_proxy to some connections.
Comment 3 Juan Saavedra 2011-05-09 10:22:51 EDT
Setting up a proxy seems to be setting envirnoment variables ok.

A problem persists, because http_proxy nor HTTP_PROXY are set even if configured manually in the gnome dialog box.

¿Has anyone this same issue?

Greets.
Comment 4 Mikhail Kryshen 2011-05-26 11:05:17 EDT
Have the same problem. Proxy is configured in network settings. In gnome-terminal https_proxy is set to http://<server>:<port>, http_proxy is not set.

Also, why is this bug related to gnome-terminal? I think that any application launched from gnome-shell should see these variables.
Comment 5 Michal Nowak 2011-06-02 19:12:19 EDT
Moving to "control-center" component as I believe it handles "Control Center -> Network".

As I see this, when I set up proxy for HTTP is does not propagate to environment variable (as one can easily check in gnome-terminal - $http_proxy nor $HTTP_PROXY is set) but HTTPS_PROXY and others do propagate.

Can anyone have a look, please?
Comment 6 Michal Nowak 2011-06-03 08:35:51 EDT
Filed upstream as https://bugzilla.gnome.org/show_bug.cgi?id=651778.
Comment 7 Michal Nowak 2011-06-03 09:34:24 EDT
Switching to gnome-terminal per upstream.
Comment 8 Dan Winship 2011-06-06 11:56:34 EDT
Created attachment 503263 [details]
patch to fedora package

Here's a patch to the Fedora package. (I don't have commit access to it.) The patch it adds has already been committed upstream.
Comment 9 Fedora Admin XMLRPC Client 2012-01-10 10:45:27 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 10 Fedora Admin XMLRPC Client 2012-01-10 10:48:02 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 11 Dan Winship 2012-07-10 13:37:40 EDT
not sure if the patch above ever got committed to Fedora, but it's been fixed in the upstream sources since 3.2

Note You need to log in before you can comment on or make changes to this bug.