Bug 699290 - [abrt] rhythmbox-2.90.1-6.git20110328.fc15: g_str_hash: Process /usr/bin/rhythmbox was killed by signal 11 (SIGSEGV)
Summary: [abrt] rhythmbox-2.90.1-6.git20110328.fc15: g_str_hash: Process /usr/bin/rhyt...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rhythmbox
Version: 15
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e6a61e20fc13e9b6c8058eaeb24...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-24 22:02 UTC by gatlibs
Modified: 2018-04-11 13:40 UTC (History)
6 users (show)

Fixed In Version: rhythmbox-2.90.1-10.git20110502.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-25 17:53:38 UTC
Type: ---


Attachments (Terms of Use)
File: event_log (20.04 KB, text/plain)
2011-04-24 22:02 UTC, gatlibs
no flags Details
File: build_ids (8.25 KB, text/plain)
2011-04-24 22:02 UTC, gatlibs
no flags Details
File: dsos (61.33 KB, text/plain)
2011-04-24 22:02 UTC, gatlibs
no flags Details
File: maps (78.25 KB, text/plain)
2011-04-24 22:02 UTC, gatlibs
no flags Details
File: backtrace (40.01 KB, text/plain)
2011-04-24 22:03 UTC, gatlibs
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 647032 0 None None None Never

Description gatlibs 2011-04-24 22:02:46 UTC
abrt version: 2.0.1
comment: I clicked the "Missing Files". Also, on Gnome3, the icon in the bottom right stayed after Rhythmbox died and was restarted.
executable: /usr/bin/rhythmbox
cmdline: rhythmbox
component: rhythmbox
uid: 500
kernel: 2.6.38.2-9.fc15.x86_64
crash_function: g_str_hash
package: rhythmbox-2.90.1-6.git20110328.fc15
reason: Process /usr/bin/rhythmbox was killed by signal 11 (SIGSEGV)
architecture: x86_64
username: gatlibs
rating: 4
time: 1303680978
os_release: Fedora release 15 (Lovelock)

Text file: event_log, 20520 bytes
Text file: build_ids, 8446 bytes
Binary file: coredump, 81817600 bytes
Text file: dsos, 62803 bytes
Text file: maps, 80133 bytes
Text file: backtrace, 40969 bytes

environ
-----
XDG_SESSION_ID=1
HOSTNAME=gat
IMSETTINGS_INTEGRATE_DESKTOP=yes
SHELL=/bin/bash
TERM=dumb
HISTSIZE=1000
XDG_SESSION_COOKIE=f8cb5eea8d422181ed1c7b920000000e-1303587893.946120-2063215999
IMSETTINGS_MODULE=none
USER=gatlibs
USERNAME=gatlibs
MAIL=/var/spool/mail/gatlibs
PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/gatlibs/bin
DESKTOP_SESSION=gnome
QT_IM_MODULE=xim
PWD=/home/gatlibs
XMODIFIERS=@im=none
LANG=en_US.utf8
GDM_LANG=en_US.utf8
GDMSESSION=gnome
SSH_ASKPASS=/usr/libexec/openssh/x11-ssh-askpass
HISTCONTROL=ignoredups
HOME=/home/gatlibs
SHLVL=1
LOGNAME=gatlibs
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-6kEDmEMFFB,guid=e97a61edad477e21cfd9f01a00000023
'LESSOPEN=||/usr/bin/lesspipe.sh %s'
ENABLE_D_LOG=1
WINDOWPATH=1
XDG_RUNTIME_DIR=/run/user/gatlibs
DISPLAY=:0
G_BROKEN_FILENAMES=1
XAUTHORITY=/var/run/gdm/auth-for-gatlibs-obb0DU/database
_=/usr/bin/gnome-session
GNOME_DESKTOP_SESSION_ID=this-is-deprecated
SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1302,unix/unix:/tmp/.ICE-unix/1302
ORBIT_SOCKETDIR=/tmp/orbit-gatlibs
GNOME_KEYRING_CONTROL=/tmp/keyring-nDlsO3
SSH_AUTH_SOCK=/tmp/keyring-nDlsO3/ssh
GPG_AGENT_INFO=/tmp/keyring-nDlsO3/gpg:0:1
GJS_DEBUG_OUTPUT=stderr
'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
DESKTOP_STARTUP_ID=gnome-shell-1511-gat-rhythmbox-18_TIME57073866
GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/rhythmbox.desktop
GIO_LAUNCHED_DESKTOP_FILE_PID=4995

Comment 1 gatlibs 2011-04-24 22:02:50 UTC
Created attachment 494571 [details]
File: event_log

Comment 2 gatlibs 2011-04-24 22:02:52 UTC
Created attachment 494572 [details]
File: build_ids

Comment 3 gatlibs 2011-04-24 22:02:55 UTC
Created attachment 494573 [details]
File: dsos

Comment 4 gatlibs 2011-04-24 22:02:58 UTC
Created attachment 494574 [details]
File: maps

Comment 5 gatlibs 2011-04-24 22:03:01 UTC
Created attachment 494575 [details]
File: backtrace

Comment 6 gatlibs 2011-04-25 00:32:10 UTC
Package: rhythmbox-2.90.1-6.git20110328.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
I clicked the "Missing Files". Also, on Gnome3, the icon in the bottom right stayed after Rhythmbox died and was restarted.

Comment 7 jeremy 2011-05-03 12:47:11 UTC
Package: rhythmbox-2.90.1-6.git20110328.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
I right clicked on the CD. The outline of the menu appeared and Rhythmbox disapeared.

Comment 8 Frans Mosch 2011-05-04 18:20:14 UTC
Package: rhythmbox-0.13.3-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.
3.
I clicked on "Quit"

Comment 9 jeremy 2011-05-07 09:01:59 UTC
Package: rhythmbox-2.90.1-6.git20110328.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
New tracks didn't appear in the catalogue so I clicked on Missing Files and Rhythmbox disapeared.

Comment 10 jeremy 2011-05-07 09:39:35 UTC
Package: rhythmbox-2.90.1-6.git20110328.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Inserted CD

Comment 11 Arif Tri Waluyo 2011-05-13 07:29:02 UTC
Package: rhythmbox-2.90.1-6.git20110328.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
1. I set Rhythmbox watch my music folder
2. Quit Rhythmbox, delete some files and folder in the music folder
3. Launch Rhythmbox, there is exclamation icon (tell about Missing files), click on that
4. Crash.

Comment 12 Arif Tri Waluyo 2011-05-13 18:40:07 UTC

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 13 mooch443 2011-05-14 11:56:21 UTC
Package: rhythmbox-2.90.1-6.git20110328.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Rythmbox crashed when trying to view "Missing files" - this is reproducable in my case. It crashes everytime. I have to add that this is maybe because I deleted many files from my library (move to trash), but didnt click on "delete" so they are still in my library. Maybe - for the future - try to delete files directly from library and disk when I click on "move to trash"?

Comment 14 Steven Stern 2011-05-15 17:40:01 UTC
Package: rhythmbox-2.90.1-6.git20110328.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Deleted some files, then clicked on "Missing  Files" to remove from rhythbox library.

Comment 15 Gerard Ryan 2011-05-16 01:56:40 UTC
Package: rhythmbox-2.90.1-6.git20110328.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
I highlighted a selection of tracks, moved to trash from right-click menu. The there was a missing files section added to the left-hand pane, so I clicked on that to see what was up, then crash.

Comment 16 Jean-François Fortin Tam 2011-05-20 00:06:46 UTC
Package: rhythmbox-2.90.1-6.git20110328.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Trying to access the "Missing files" category in the sidebar

Comment 17 Jean-François Fortin Tam 2011-05-20 16:15:17 UTC
This seems to happen whenever I try to switch workspaces from rhythmbox (or toggle the activity overview) in gnome-shell. It is extremely annoying and makes it impossible to use rhythmbox at all. Seems to have started happening only since yesterday's updates to F15.

Comment 18 Sébastien LOSS 2011-05-21 15:52:40 UTC
Package: rhythmbox-2.90.1-6.git20110328.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Playing with GNOME 3 switcher (ALT+Tab) I notice that :

pressing ALT in Rhythmbox (when the main window is focused) crashes it immediatly ! Strange isn't it ?
Rhythmbox applet/indicator stay in the trail .... orphaned.

Bye

Comment 19 Angus Salkeld 2011-05-23 03:16:21 UTC
Package: rhythmbox-2.90.1-6.git20110328.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
just Alt-tabbed to give it focus

Comment 20 Jean-François Fortin Tam 2011-05-23 15:20:32 UTC
Okay, some more precision/clarification on this. This does not happen when triggering gnome-shell's overview mode (unlike what I said in my previous comment).

To summarize the comments and observations on this bug report, there are two ways to reproduce this:
- clicking on "Missing files" in the RB sidebar
- pressing the Alt button on the keyboard (which is what I used to do ctrl+alt+up/down to switch workspaces)

Comment 21 Arif Tri Waluyo 2011-05-25 16:12:30 UTC

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 22 Matěj Cepl 2011-05-25 17:53:38 UTC
We filed this bug in the upstream database (https://bugzilla.gnome.org/show_bug.cgi?id=647032) and believe that it is more appropriate to let it be resolved upstream.

We will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

We would strongly encourage you to subscribe to the upstream bug as well (by logging in and adding yourself to the Cc list), so that you can provide whatever information required for the successful resolving of this issue.

Thank you for helping to make free software better.

Comment 23 Fedora Update System 2011-05-25 19:33:55 UTC
rhythmbox-2.90.1-10.git20110502.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/rhythmbox-2.90.1-10.git20110502.fc15

Comment 24 gatlibs 2011-05-25 20:44:59 UTC
Rhythmbox still dies when one clicks the 'Preferences' button after selection 'Song Lyrics' is clicked under the plugins menu.

Comment 25 Matěj Cepl 2011-05-25 22:56:56 UTC
(In reply to comment #24)
> Rhythmbox still dies when one clicks the 'Preferences' button after selection
> 'Song Lyrics' is clicked under the plugins menu.

This is a different bug in Song Lyrics plugin and it has been already filed upstream as https://bugzilla.gnome.org/show_bug.cgi?id=650801. Join the fellowship there.

Comment 26 Fedora Update System 2011-05-27 20:25:17 UTC
rhythmbox-2.90.1-10.git20110502.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 27 Rutger Bazen 2011-07-02 09:31:14 UTC
I have a reproducible crash with version 2.90.1.10.git20110502.fc15

Fedora 15, Gnome3, Gnome-shell
Tried to report using ABRT, but that marks it as a duplicate of this bug.

Rhythmbox crashes when rhythmbox loses focus due to desktop switch (Control+Alt+Up/Down)

When a different application has focus, rhythmbox does NOT crash on switch.

Steps to reproduce:
1) Start rhythmbox
2) Move to different workspace when Rhythmbox has focus
3) Crash

Comment 28 Rutger Bazen 2011-07-02 09:46:41 UTC
Also, clicking on "Missing Files" causes a crash.


Note You need to log in before you can comment on or make changes to this bug.