Bug 69936
| Summary: | quotas, highuids, largefilesystems... not working | ||
|---|---|---|---|
| Product: | [Retired] Red Hat Linux | Reporter: | Andrew Sydelko <sydelko> |
| Component: | quota | Assignee: | Phil Copeland <copeland> |
| Status: | CLOSED DUPLICATE | QA Contact: | Brock Organ <borgan> |
| Severity: | medium | Docs Contact: | |
| Priority: | medium | ||
| Version: | 7.3 | CC: | thoron |
| Target Milestone: | --- | ||
| Target Release: | --- | ||
| Hardware: | i386 | ||
| OS: | Linux | ||
| Whiteboard: | |||
| Fixed In Version: | Doc Type: | Bug Fix | |
| Doc Text: | Story Points: | --- | |
| Clone Of: | Environment: | ||
| Last Closed: | 2002-08-07 18:06:04 UTC | Type: | --- |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
Ok lets see what we get with quota-3.06 (current rawhide and also errata
candidate for 7.x series)
[root@alpha home]# useradd -m high -u 75535
[root@alpha home]# edquota high
[root@alpha home]# quota high
Disk quotas for user high (uid 75535):
Filesystem blocks quota limit grace files quota limit grace
/dev/sda2 44 1000 10000 12 0 0
[root@alpha home]# ls -a ~high
. .. .bash_logout .bash_profile .bashrc .emacs .gtkrc .kde .screenrc
[root@alpha home]# useradd -m low -u 5535
[root@alpha home]# edquota low
[root@alpha home]# quota low
Disk quotas for user low (uid 5535):
Filesystem blocks quota limit grace files quota limit grace
/dev/sda2 44 1000 10000 12 0 0
[root@alpha home]# ls -a ~low
. .. .bash_logout .bash_profile .bashrc .emacs .gtkrc .kde .screenrc
Works for me
Phil
=--=
Recompile of quota-3.06-2.src.rpm from rawhide on a RedHat 7.3 machine still does not work The problem is not _just_ high-uid but a combination of high-uid and large filesystem (in this case >400GB). From the reply you gave, I have no idea how big /dev/sda2 is, so I have no idea if the problem is solved. So, I'm reopening the bug. 400Gb? Sorry, we don't have the resources to check something like that! I'm lucky to get anything bigger than 32Gb for disk here. Most of the machines I have here have only 4Gb or 18Gb HD's in them. Filesystem 1k-blocks Used Available Use% Mounted on /dev/sda2 3351288 3069968 280920 92% / Phil =--= Just because you don't have the resources doesn't mean the bug doesn't exist. This should stay open until someone can find the resources and fix it. We'll continue to look into the problem on our end. --andy. |
From Bugzilla Helper: User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020610 Debian/1.2.5-1 Description of problem: Config: Dell 2550 with 2 8x73GB RAID-5 Powervault boxes. RedHat 7.3 Kernel 2.4.18-4smp quota-3.03-1 Each powervault is a separate ext3 filesystem using hardware raid-5. With a user named arslan and a uid of 78276 running 'edquota arslan' spits out: edquota: Error while getting quota from /dev/sdc1 for 78276: Invalid argument edquota: Error while getting quota from /dev/sdd1 for 78276: Invalid argument and then kicks me into vi with another smaller filesystem listed, but not the two big ones. This does not fail for a user with a UID of 13465, i.e. all three quotaed filesystems show up for editing using edquota. Version-Release number of selected component (if applicable): How reproducible: Always Steps to Reproduce: 1. Create filesystems as such: /dev/sdc1 493022304 123330440 369291864 26% /export/home/a /dev/sdd1 493022304 13232988 479389316 3% /export/home/b /dev/sda6 3889892 32836 3659460 1% /spare1 using ext3 and turning on quotas. 2. Create a user with a high UID (>65535) and run edquota for that user. 3. Create a user with a low UID (<65535) and run edquota for that user. Actual Results: For step 2. I get the following error message: edquota: Error while getting quota from /dev/sdc1 for 78276: Invalid argument edquota: Error while getting quota from /dev/sdd1 for 78276: Invalid argument and then a vi session with: Disk quotas for user arslan (uid 78276): Filesystem blocks soft hard inodes soft hard /dev/sda6 0 0 0 0 0 0 For step 3, I get no error message and the vi session shows: Disk quotas for user sydelko (uid 13465): Filesystem blocks soft hard inodes soft hard /dev/sdc1 0 0 0 0 0 0 /dev/sdd1 0 0 0 0 0 0 /dev/sda6 0 0 0 0 0 0 Expected Results: It should work... Additional info: