Bug 69939 - mailq lacks permissions to chdir(/var/spool/mqueue/)
mailq lacks permissions to chdir(/var/spool/mqueue/)
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: sendmail (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-26 13:08 EDT by Todd Allen
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-29 00:27:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Todd Allen 2002-07-26 13:08:01 EDT
Description of Problem:

Either /usr/bin/mailq or /var/spool/mqueue doesn't have the right permissions,
because mailq gets an error every time.

Version-Release number of selected component (if applicable):

sendmail-8.12.4-3

How Reproducible:

Every time.

Steps to Reproduce:
1. mailq

Actual Results:

can not chdir(/var/spool/mqueue/): Permission denied
Program mode requires special privileges, e.g., root or TrustedUser.

Expected Results:

/var/spool/mqueue is empty

Additional Information:
Comment 1 Bill Nottingham 2002-07-29 00:27:16 EDT
Are you root, or have you set up a trusted user?
Comment 2 Todd Allen 2002-07-29 09:44:16 EDT
So, you're implying this is an intention change, and that a normal user isn't
supposed to be able to use mailq any more?  That hadn't even crossed my mind.
But now that I look for it, I see there's a note in the SECURITY file to that
effect.  Well, if it's intentional, I guess it isn't a bug.  Sorry for the false
alarm.

Note You need to log in before you can comment on or make changes to this bug.