Bug 699434 - Wireless very slow with Intel 802.11n (Intel PRO/Wireless 4965 AGN)
Wireless very slow with Intel 802.11n (Intel PRO/Wireless 4965 AGN)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-25 12:02 EDT by Manuel Rego
Modified: 2012-02-02 12:21 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-02 12:21:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Manuel Rego 2011-04-25 12:02:48 EDT
Using Fedora 15 in a Dell XPS M1330 and the following wireless card: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection

Wireless connection is really slow while wired it works like a charm.

In order to fix it I've disabled N following instructions at: http://fedoraproject.org/wiki/Common_F14_bugs#intel_80211n
Comment 1 Jirka Klimes 2011-05-02 08:08:53 EDT
Reassigning to kernel to see if there are any changes about this.
Comment 2 Stanislaw Gruszka 2011-06-15 05:27:45 EDT
Manuel, can you test compat-wireless-next from http://people.redhat.com/sgruszka/compat_wireless.html ? It include some iwl4965 patches that could possibly fix this problem, please give it a try and report back.
Comment 3 Stanislaw Gruszka 2011-06-27 07:06:17 EDT
Also, patches which could fix this problem, are already in 3.0-x i.e rawhide kernel.
Comment 4 Stanislaw Gruszka 2011-07-13 09:13:31 EDT
Closing due to lack of response ...
Comment 5 Manuel Rego 2011-07-25 10:22:00 EDT
(In reply to comment #2)
> Manuel, can you test compat-wireless-next from
> http://people.redhat.com/sgruszka/compat_wireless.html ? It include some
> iwl4965 patches that could possibly fix this problem, please give it a try and
> report back.

I've tested it and I don't notice any change in my wireless connection (I still the line disabling N to have a common wireless connection working).

I've tried to upgrade to rawhide without success, so I think that I can't help more for the moment. I hope it's fixed in future Fedora 16.
Comment 6 Stanislaw Gruszka 2011-07-25 10:38:32 EDT
Did you try compat-wireless-next or just compat-wireless?
Comment 7 Manuel Rego 2011-07-26 02:48:33 EDT
I tested compat-wireless-next, but I had problems to restart my laptop. I was able to restart it only with console, and then use "yum update" there, after that my laptop restart properly but wireless keep working slow.

Once I upgraded to rawhide laptop doesn't start properly anymore.
Comment 8 TL 2011-08-14 23:48:23 EDT
Not sure if this is the right bug to post to, but after installing Fedora 15 on my Sony Vaio VGN-SZ680, which has the Intel PRO/Wireless 4965 chipset, 802.11n "N" networking doesn't seems to work any more.  802.11g "G" access points are visible, and work, but the "N" APs have disappeared, and even if I try to connect directly to 'hidden' "N" APs, it tries and fails repeatedly, such that no "N" networking works.
Comment 9 Stanislaw Gruszka 2011-08-15 03:58:43 EDT
Unfortunately I'm not able to reproduce this problem, my iwl4965 works pretty well on 11n network. Maybe this problem depends on AP type you are using, please provide your AP type and settings, perhaps I'll be able to get the same AP. If not I'll asking for more verbose debugging information.
Comment 10 Manuel Rego 2011-08-15 08:24:57 EDT
In my case I'm using a Fonera 2.0n, more info here: http://wiki.fon.com/wiki/Fonera_2.0n
Comment 11 TL 2011-08-15 09:41:34 EDT
Thanks for the reply, but for some reason it is actually *all* the 11n networks.  No 11n APs show up at all (there are about 10), only 11g APs.  One other thing, this seems to have happened after one of the routine YUM updates from Fedora.  11n used to work fine on my F15 instance.  Now, at some point during the last few weeks, all the 11n APs disappeared.  Even when I try to connect to my own Cisco 11n AP directly as a 'hidden' network, my Fedora instance keeps throwing the WPA authentication dialog up again and again, repeatedly, never successfully connecting.  All the other WIFI devices in my house connect to the same Cisco 11n AP fine.  My F15 instance only sees and works with Gs.
Comment 12 Stanislaw Gruszka 2011-08-15 11:42:00 EDT
If you do as root 

iwlist wlan5 scan | grep SSID

does it show other APs?

You can use "yum history info LATEST_ID" (see  "yum history list" to see transaction IDs) to check if there was update of NetworkManager .
Comment 13 Stanislaw Gruszka 2011-08-15 11:42:52 EDT
(In reply to comment #12)
> iwlist wlan5 scan | grep SSID
Instead of wlan5 use whatever iwconfig show.
Comment 14 TL 2011-08-15 21:42:39 EDT
Yes, it shows all the 802.11*G* APs, but not any of the 11n APs (there are at least 10 11n APs that should show up, including mine).  Notice all of the APs are 2.4 GHZ.  Here is the output:

[root@fedora-15 ~]# iwlist wlan0 scan | grep -B 3 SSID 

                    Frequency:2.437 GHz (Channel 6)
                    Quality=34/70  Signal level=-76 dBm  
                    Encryption key:on
                    ESSID:"kathleen"
--
                    Frequency:2.437 GHz (Channel 6)
                    Quality=23/70  Signal level=-87 dBm  
                    Encryption key:on
                    ESSID:"badcats"
--
                    Frequency:2.462 GHz (Channel 11)
                    Quality=44/70  Signal level=-66 dBm  
                    Encryption key:on
                    ESSID:"Adrienne"
--
                    Frequency:2.462 GHz (Channel 11)
                    Quality=62/70  Signal level=-48 dBm  
                    Encryption key:on
                    ESSID:"ProNet"
--
                    Frequency:2.412 GHz (Channel 1)
                    Quality=21/70  Signal level=-89 dBm  
                    Encryption key:on
                    ESSID:"CherryBomb"
--
                    Frequency:2.417 GHz (Channel 2)
                    Quality=30/70  Signal level=-80 dBm  
                    Encryption key:on
                    ESSID:"MacGruber"
--
                    Frequency:2.427 GHz (Channel 4)
                    Quality=23/70  Signal level=-87 dBm  
                    Encryption key:on
                    ESSID:"Superfly"
--
                    Frequency:2.447 GHz (Channel 8)
                    Quality=23/70  Signal level=-87 dBm  
                    Encryption key:on
                    ESSID:"frognet-LR"
--
                    Frequency:2.462 GHz (Channel 11)
                    Quality=22/70  Signal level=-88 dBm  
                    Encryption key:on
                    ESSID:"money"
--
                    Frequency:2.457 GHz (Channel 10)
                    Quality=23/70  Signal level=-87 dBm  
                    Encryption key:on
                    ESSID:"forbin project"
--
                    Frequency:2.412 GHz (Channel 1)
                    Quality=24/70  Signal level=-86 dBm  
                    Encryption key:on
                    ESSID:"Dublin"
--
                    Frequency:2.412 GHz (Channel 1)
                    Quality=23/70  Signal level=-87 dBm  
                    Encryption key:on
                    ESSID:"2987"
--
                    Frequency:2.437 GHz (Channel 6)
                    Quality=20/70  Signal level=-90 dBm  
                    Encryption key:off
                    ESSID:"NETGEAR"
--
                    Frequency:2.462 GHz (Channel 11)
                    Quality=20/70  Signal level=-90 dBm  
                    Encryption key:on
                    ESSID:"L-Apple-A5"
Comment 15 TL 2011-08-15 21:48:27 EDT
In regard to your second point about when NetworkManager was last updated by YUM, it looks like it was on August 3rd:

[root@localhost ~]# yum history info 36 
Loaded plugins: langpacks, presto, refresh-packagekit
Transaction ID : 36
Begin time     : Wed Aug  3 19:20:37 2011
Begin rpmdb    : 2259:87ec7f7cd744cd2e06b9876fcb7dc74717b7e996
End time       :            19:27:48 2011 (7 minutes)
End rpmdb      : 2260:d5b00b09760565fc3fadb7d00f7ccb7e8580b27c
User           : tlp <tlp>
Return-Code    : Success
Command Line   : update
Transaction performed with:
    Installed     rpm-4.9.0-9.fc15.i686
    Updated       yum-3.2.29-7.fc15.noarch
    Installed     yum-metadata-parser-1.1.4-4.fc15.i686
    Installed     yum-presto-0.6.2-3.fc15.noarch
Packages Altered:
    Updated     NetworkManager-1:0.8.9997-5.git20110702.fc15.i686
    Update                     1:0.8.9997-6.git20110721.fc15.i686
    Updated     NetworkManager-glib-1:0.8.9997-5.git20110702.fc15.i686
    Update                          1:0.8.9997-6.git20110721.fc15.i686
    Updated     NetworkManager-gnome-1:0.8.9997-5.git20110702.fc15.i686
    Update                           1:0.8.9997-6.git20110721.fc15.i686
    Updated     NetworkManager-openvpn-1:0.8.999-1.fc15.i686
    Update                             1:0.8.9997-2.git20110721.fc15.i686
    Updated     NetworkManager-pptp-1:0.8.999-1.fc15.i686
    Update                          1:0.8.999-2.git20110721.fc15.i686
    Updated     NetworkManager-vpnc-1:0.8.999-2.fc15.i686
    Update                          1:0.8.999-3.git20110721.fc15.i686
[... etc.. ]
Comment 16 Stanislaw Gruszka 2011-08-16 05:33:12 EDT
Seems this is scanning problem, please open separate bug for it, and assaing it to me.
Comment 17 Stanislaw Gruszka 2011-08-22 10:59:54 EDT
(In reply to comment #10)
> In my case I'm using a Fonera 2.0n, more info here:
> http://wiki.fon.com/wiki/Fonera_2.0n

Looks cool. However I'm going to order to TL-WR1043ND , because I have 3 separate bug reports where this AP cause troubles (with Open-Wrt firmware). Hopefully one of these problems could be also a issue here ...
Comment 18 Manuel Rego 2011-08-22 11:43:36 EDT
(In reply to comment #17)
> (In reply to comment #10)
> > In my case I'm using a Fonera 2.0n, more info here:
> > http://wiki.fon.com/wiki/Fonera_2.0n
> 
> Looks cool. However I'm going to order to TL-WR1043ND , because I have 3
> separate bug reports where this AP cause troubles (with Open-Wrt firmware).
> Hopefully one of these problems could be also a issue here ...

I'm having less troubles since I changed the configuration of my wireless network to WPA2 (AES).

Now, it seems that everything is working right, even without the workaround at /etc/modprobe.d/intel-80211n.conf file.

So, maybe the problem were just with WPA or it was fixed in some upgrade now I'm running kernel 2.6.40.
Comment 19 Josh Boyer 2012-02-02 12:21:20 EST
Closing this out.  The last comment was 5 months ago and indicated things were working now.

Note You need to log in before you can comment on or make changes to this bug.