Bug 699544 - dhclient will not start after boot on rhel5.7
dhclient will not start after boot on rhel5.7
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: initscripts (Show other bugs)
5.7
x86_64 Linux
urgent Severity urgent
: beta
: 5.7
Assigned To: initscripts Maintenance Team
qe-baseos-daemons
: Regression
: 699593 699775 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-25 17:53 EDT by Adam Okuliar
Modified: 2013-01-21 15:00 EST (History)
6 users (show)

See Also:
Fixed In Version: initscripts-8.45.35-2.el5
Doc Type: Bug Fix
Doc Text:
After system installation, the dhclient utility failed to start after boot on an interface configured to get an IPv4 address from DHCP. This bug has been fixed and the dhclient utility now starts properly in the described scenario.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-21 04:34:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
compressed content of /etc/sysconfig directory (57.06 KB, application/x-gzip)
2011-04-27 03:56 EDT, Adam Okuliar
no flags Details
compressed content of /var/log directory (206.86 KB, application/x-gzip)
2011-04-27 03:57 EDT, Adam Okuliar
no flags Details

  None (edit)
Description Adam Okuliar 2011-04-25 17:53:54 EDT
Description of problem:


Version-Release number of selected component (if applicable):
RHEL5.7-Server-20110422.0.n_nfs-x86_64

How reproducible:
100%

Steps to Reproduce:
1. Provision some machine with RHEL5.7-Server-20110422.0.n_nfs-x86_64 

2. After installation, interface from which was system installed, should be configured to get IPv4 address from dhcp. 

3. Make sure that installation interface is configured to get IP from DHCP and enabled on boot. 

cat /etc/sysconfig/network-scripts/ifcfg-eth0 
# Intel Corporation 82576 Gigabit Network Connection
DEVICE=eth0
BOOTPROTO=dhcp
HWADDR=1C:C1:DE:E8:FA:8E
ONBOOT=yes

4. ip a l dev eth0 to show ip addresses on interface
 eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop qlen 1000
    link/ether 1c:c1:de:e8:fa:8e brd ff:ff:ff:ff:ff:ff

5. ps aux | grep dhclient 
root      3962  0.0  0.0  61184   812 ttyS0    S+   17:50   0:00 grep dhclient

Actual results:
dhclient won't start after boot

Expected results:
dhclient will start and configure ip address on interface

Additional info:
when launching dhclient eth0 manually network will start without any problems.
Comment 1 Bill Nottingham 2011-04-25 21:35:38 EDT
What's the output of 'chkconfig --list network', just to get the obvious stuff out of the way?
Comment 2 Adam Okuliar 2011-04-26 06:49:35 EDT
# chkconfig --list network
network        	0:off	1:off	2:on	3:on	4:on	5:on	6:off

# service network status
/etc/init.d/network: line 53: -e: command not found
Configured devices:
lo
Currently active devices:
lo

# service network start
/etc/init.d/network: line 53: -e: command not found
Bringing up loopback interface:  [  OK  ]
RTNETLINK answers: File exists
RTNETLINK answers: File exists
RTNETLINK answers: File exists
RTNETLINK answers: File exists
RTNETLINK answers: File exists
RTNETLINK answers: File exists
RTNETLINK answers: File exists
RTNETLINK answers: File exists
RTNETLINK answers: File exists

after service network start eth0 interface is still down
Comment 3 Bill Nottingham 2011-04-26 15:14:15 EDT
Can you post/attch the output of "ls /etc/sysconfig/network-scripts", please?
Comment 4 Bill Nottingham 2011-04-26 15:17:48 EDT
*** Bug 699593 has been marked as a duplicate of this bug. ***
Comment 5 Bill Nottingham 2011-04-26 15:19:02 EDT
This looks like a mismerged patch.

RHEL 5.7 has:

            LANG=C sed -e "$__sed_discard_ignored_files" \
                       -e '/\(ifcfg-lo\|:\|ifcfg-.*-range\)/d' \
                       -e '/ifcfg-[A-Za-z0-9\._-]\+$/ { s/^ifcfg-//g;s/[0-9]/ &/}' | \
                       -e '/\(ifcfg-lo$\|:\|ifcfg-.*-range\)/d' \
                       -e '/ifcfg-[A-Za-z0-9#\._-]\+$/ { s/^ifcfg-//g;s/[0-9]/ &/}' | \

RHEL 6.1 has:

            LANG=C sed -e "$__sed_discard_ignored_files" \
                       -e '/\(ifcfg-lo$\|:\|ifcfg-.*-range\)/d' \
                       -e '/ifcfg-[A-Za-z0-9#\._-]\+$/ { s/^ifcfg-//g;s/[0-9]/ &/}' | \
Comment 6 Adam Okuliar 2011-04-27 03:56:11 EDT
Created attachment 495141 [details]
compressed content of /etc/sysconfig directory
Comment 7 Adam Okuliar 2011-04-27 03:57:09 EDT
Created attachment 495142 [details]
compressed content of /var/log directory
Comment 8 Adam Okuliar 2011-04-27 03:58:48 EDT
I added gzip-ed content of /var/log and /etc/sysconfig directory. 

Thanks,
Adam
Comment 10 Radek Bíba 2011-04-27 07:27:17 EDT
Yay, "service network status", which had problems with the previous version, is okay now. However, I'm afraid I can't test anything more at the moment as I'd like to keep the system running and online. Adam, do you have a machine where you can update the package and play with network?
Comment 11 Adam Okuliar 2011-04-27 07:35:23 EDT
Hi,

I tested package posted above (from Harald) and everything seems to be OK with this version.

Thanks
Adam
Comment 12 Harald Hoyer 2011-04-27 08:15:08 EDT
*** Bug 699775 has been marked as a duplicate of this bug. ***
Comment 14 RHEL Product and Program Management 2011-04-27 08:59:22 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 18 Adam Okuliar 2011-04-27 12:59:10 EDT
reproduced on initscripts-8.45.35-1.el5
verified with initscripts-8.45.35-2.el5

Thanks Harald!
Adam
Comment 19 Tomas Capek 2011-07-13 08:20:10 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
After system installation, the dhclient utility failed to start after boot on an interface configured to get an IPv4 address from DHCP. This bug has been fixed and the dhclient utility now starts properly in the described scenario.
Comment 20 errata-xmlrpc 2011-07-21 04:34:37 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1081.html
Comment 21 errata-xmlrpc 2011-07-21 08:41:07 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1081.html

Note You need to log in before you can comment on or make changes to this bug.