Bug 699615 - xendomains: cannot start without domain to restore or to create
Summary: xendomains: cannot start without domain to restore or to create
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen
Version: 5.7
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Miroslav Rezanina
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 699611
TreeView+ depends on / blocked
 
Reported: 2011-04-26 07:47 UTC by Yuyu Zhou
Modified: 2012-02-21 05:54 UTC (History)
5 users (show)

Fixed In Version: xen-3.0.3-133.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-21 05:54:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0160 normal SHIPPED_LIVE xen bug fix and enhancement update 2012-02-20 14:53:33 UTC

Description Yuyu Zhou 2011-04-26 07:47:36 UTC
Description of problem:
Xendomains failed to start when there is no guest image in /var/lib/xen/save for restore and no guest configure file in /etc/xen/auto.
In fact, according to /tools/examples/init.d/xendomains, nothing will do in this condition. I think this may be not graceful enough, may mislead our users.

Version-Release number of selected component (if applicable):
xen-3.0.3-129.el5

How reproducible:
100%

Steps to Reproduce:
1. shutdown all the guest
2. empty /var/lib/xen/save
3. empty /etc/xen/auto
4. $ /etc/inti.d/xendomains restart
5. $ /etc/inti.d/xendomains status

Actual results:
On step 5:
Checking for xendomains:[unused]                           [FAILED]

Expected results:
On step 5:
Checking for xendomains:[running]                          [  OK  ]

Comment 4 Qixiang Wan 2011-12-05 06:29:49 UTC
Verified with xen-3.0.3-135.el5. The output of 'service xendomains status' has been improved, no 'FAILED' message display when there is nothing to be done with xendomains.

[root@localhost ~]# rpm -q xen
xen-3.0.3-135.el5
[root@localhost ~]# /etc/init.d/xendomains restart
Shutting down Xen domains:[root@localhost ~]# /etc/init.d/xendomains status
xendomains is stopped
[root@localhost ~]# touch /var/lock/subsys/xendomains
[root@localhost ~]# /etc/init.d/xendomains status
Checking for xendomains:[running]                          [  OK  ]

Comment 5 errata-xmlrpc 2012-02-21 05:54:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0160.html


Note You need to log in before you can comment on or make changes to this bug.