Bug 69967 - up2date -f does not work to get the new kernel
up2date -f does not work to get the new kernel
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: up2date (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-26 20:53 EDT by Nigel Smith
Modified: 2015-01-07 18:58 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-21 04:34:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nigel Smith 2002-07-26 20:53:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; T312461; .NET 
CLR 1.0.3705)

Description of problem:
Installation of the kernel is, by default, skipped by up2date.
With previous versions of RedHat, I have used the option -f to force 
installation of the kernel, but with Limbo, it just keeps on skipping the 
package.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.up2date -d -f kernel
2.
3.
	

Actual Results:  #up2date -d -f kernel
Adding cert <X509Name object '/C=US/ST=North Carolina/L=Research Triangle 
Park/O=Red Hat, Inc./OU=Red Hat Network Services/CN=RHNS Certificate 
Authority/Email=rhns@redhat.com'>

Fetching package list for channel: redhat-beta-limbo-i386...

Fetching Obsoletes list for channel: redhat-beta-limbo-i386...
The following Packages were marked to be skipped by your configuration:

Name                                    Version        Rel  Reason
-------------------------------------------------------------------------------
kernel                                  2.4.18         5.73 Pkg name/pattern

None of the packages you requested were found, or they are already updated.
#uname -a
Linux rhlimbo 2.4.18-5.58 #1 Wed Jun 26 10:45:16 EDT 2002 i586 unknown unknown 
GNU/Linux

Expected Results:  With #up2date -d -f kernel
I expect it to download the new kernel rpm to /var/spool/up2date


Additional info:

Also tried #up2date -u -f kernel
and other variations without success.

I am using:
rhnlib-0.8-11
up2date-2.9.30-7.x.9

I am using the default values in
/etc/sysconfig/rhn/up2date
(No doubt I could get the kernel rpm by removing the 
removeSkipList=kernel*;
but the point is that using the -f should avoid having to do this)
Comment 1 Adrian Likins 2002-08-02 15:31:42 EDT
I'll take a look at this.
Comment 2 Michael Young 2002-08-21 04:16:37 EDT
I am seeing the same thing with up2date 2.9.46-1 and rhnlib-0.8-13.
Comment 3 Michael Young 2002-08-21 04:34:27 EDT
Another weird thing in my case, rhn doesn't show my system as out of date, even
though 2.4.18-11 should be older than 2.4.18-12.2. It is not obviously an epoch
bug either. Note my system is (null).
Comment 4 Nigel Smith 2002-09-03 06:44:50 EDT
Ok, this seems to be fixed with:
up2date-2.9.68-1
rhnlib-0.9-1

Note You need to log in before you can comment on or make changes to this bug.