Bug 699683 - ldapexop: ../../../libraries/liblber/io.c:186: ber_free_buf: Assertion `((ber)->ber_opts.lbo_valid==0x2)' failed.
ldapexop: ../../../libraries/liblber/io.c:186: ber_free_buf: Assertion `((ber...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openldap (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Jan Vcelak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-26 07:10 EDT by Ondrej Moriš
Modified: 2013-03-03 20:29 EST (History)
3 users (show)

See Also:
Fixed In Version: openldap-2.4.24-3.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-18 18:33:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (1001 bytes, patch)
2011-05-19 12:38 EDT, Jan Vcelak
no flags Details | Diff

  None (edit)
Description Ondrej Moriš 2011-04-26 07:10:53 EDT
Description of problem:

ldapexop query fails with assertion failure:

ldapexop: ../../../libraries/liblber/io.c:186: ber_free_buf: Assertion `((ber)->ber_opts.lbo_valid==0x2)' failed.

Version-Release number of selected component (if applicable):

openldap-2.4.24-2.fc16.i686
openldap-servers-2.4.24-2.fc16.i686
openldap-clients-2.4.24-2.fc16.i686

How reproducible:

Always.

Steps to Reproduce:

1. Setup OpenLDAP server on ldap://127.0.0.1
   + backup /var/lib/ldap, /etc/openldap/
   + rm /var/lib/ldap/* /etc/openldap* -rf
   + yum reinstall openldap*
   + service slapd start

2. ldapexop -H ldap:// -x whoami
  
Actual results:

anonymous
ldapexop: ../../../libraries/liblber/io.c:186: ber_free_buf: Assertion `((ber)->ber_opts.lbo_valid==0x2)' failed.
Aborted

Expected results:

anonymous
Comment 1 Jan Vcelak 2011-05-19 12:38:17 EDT
Created attachment 499898 [details]
proposed patch
Comment 2 Rich Megginson 2011-05-19 12:46:05 EDT
Comment on attachment 499898 [details]
proposed patch

ack
looks like res is freed on line 352
Comment 3 Jan Vcelak 2011-05-19 12:58:09 EDT
Thank you for reviewing, Rich. :)

I also created an upstream report
http://www.OpenLDAP.org/its/index.cgi?findid=6946
Comment 4 Jan Vcelak 2011-06-27 13:30:01 EDT
(This issue is resolved in Rawhide with openldap-2.4.25-1.fc16.)
Comment 5 Jan Vcelak 2011-06-28 06:42:13 EDT
Fixed in openldap-2.4.24-3.fc15
Comment 6 Fedora Update System 2011-06-28 06:46:43 EDT
openldap-2.4.24-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/openldap-2.4.24-3.fc15
Comment 7 Fedora Update System 2011-06-28 16:28:28 EDT
Package openldap-2.4.24-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openldap-2.4.24-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/openldap-2.4.24-3.fc15
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2011-07-18 18:33:18 EDT
openldap-2.4.24-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.