Bug 699692 - Broken dependency on deprecated hal
Summary: Broken dependency on deprecated hal
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xfburn   
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christoph Wickert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On: 699682 699714
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-26 11:37 UTC by Honza Horak
Modified: 2011-05-02 03:37 UTC (History)
2 users (show)

Fixed In Version: xfburn-0.4.3-5.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-27 11:01:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Honza Horak 2011-04-26 11:37:50 UTC
Description of problem:
Since HAL has been deprecated upstream for 3 years, Fedora and all major
distributions are removing it:

https://fedoraproject.org/wiki/Features/HalRemoval

The hal package has already been deprecated by its maintainer and blocked from
composes for rawhide.
Therefore, unless somebody volunteers to maintain hal, the following broken
dependencies for your package should be removed:

xfburn-0.4.3-4.fc15.x86_64 requires libhal-storage.so.1()(64bit)
xfburn-0.4.3-4.fc15.x86_64 requires libhal.so.1()(64bit)
xfburn-0.4.3-4.fc15.i686 requires libhal.so.1
xfburn-0.4.3-4.fc15.i686 requires libhal-storage.so.1


Version-Release number of selected component (if applicable):
xfburn-0.4.3-4

Comment 1 Honza Horak 2011-04-26 11:48:59 UTC
Build dependency on hal has been removed already in Rawhide.

Also build dependency on thunar-vfs has been removed in Rawhide, because thunar-vfs is depended on hal, which is deprecated. 

This change is probably temporary and dependency on thunar-vfs can be re-enabled after thunar-vfs is repaired, so this bug serves as a tracker for that change in the future.

Comment 2 Honza Horak 2011-04-26 12:54:10 UTC
The bug #699714 should be solved before this one, too. It is not possible to build xfburn in Rawhide until then.

Comment 3 Christoph Wickert 2011-04-26 15:12:36 UTC
Working on that, both exo and thunar-vfs build without hal.

Comment 4 Christoph Wickert 2011-04-27 11:01:14 UTC
Package is in rawhide, for F15 I have requested a buildroot overwrite for exo and thunar-vfs [1] to build xfburn. Once that is done all three will be deployed in one update.

[1] https://fedorahosted.org/rel-eng/ticket/4668

Comment 5 Fedora Update System 2011-04-27 12:26:27 UTC
xfburn-0.4.3-5.fc15,thunar-vfs-1.2.0-3.fc15,exo-0.6.0-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/xfburn-0.4.3-5.fc15,thunar-vfs-1.2.0-3.fc15,exo-0.6.0-5.fc15

Comment 6 Fedora Update System 2011-05-02 03:37:17 UTC
xfburn-0.4.3-5.fc15, thunar-vfs-1.2.0-3.fc15, exo-0.6.0-5.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.