Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 6997 - 6.1 Upgrade script dies if it encounters an unformatted partition.
6.1 Upgrade script dies if it encounters an unformatted partition.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-14 13:18 EST by mjm306
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-28 17:52:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mjm306 1999-11-14 13:18:59 EST
I performed a network upgrade (with boot disk via ftp) from 6.0 to 6.1. The install script died while attempting to find the partition where 6.0 was installed. The debug info indicated that it had difficulty reading /dev/hda5.

I ran fdisk. /dev/hda5 was an extended partition that was marked as ext2 but not formatted.

Formatting the partition and re-running the install solved the problem.
Comment 1 Jay Turner 1999-11-22 13:48:59 EST
This issue has been assigned to a developer for further action.
Comment 2 Michael Fulbright 2000-02-22 13:55:59 EST
If you were trying to upgrade a machine with a partition which was marked
as Linux Native, but has no valid filesystem on it, bad things are sure to
happen.

Will mark as a request for future development that we handle this case
more robustly.
Comment 3 Erik Troan 2000-04-28 17:23:59 EDT
Fixed in 6.2.

Note You need to log in before you can comment on or make changes to this bug.