Bug 69974 - Intel i830 chip support is broken.
Intel i830 chip support is broken.
Status: CLOSED DUPLICATE of bug 65661
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2002-07-27 08:03 EDT by Ivo Sarak
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-07-27 14:12:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ivo Sarak 2002-07-27 08:03:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1b) Gecko/20020726

Description of problem:
Only working mode is 640X480 (HP OmniBook XT6050).

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1) Run a Xconfigurator to set display and resolution (set resolution to 1024X768);
2) Let it start X test;

Actual Results:  It will give You an error about X configuration.
To get X working at all set the resolution to 640X480.

Expected Results:  Working X at 1024X768.

Additional info:

This chip support is broken in RedHat 7.3, too.
Comment 1 Mike A. Harris 2002-07-27 14:12:04 EDT
No, the chip support is actually not broken.  What is broken though
is the BIOS in your laptop.  If computer vendors would follow Intel's
published specifications when implementing these graphics chips on
laptops and other hardware, then people would not have these problems.

Somewhere on developer.intel.com is a page describing how many laptop
manufacturers have designed their laptop BIOS's against Intel's specifications.

This is the reason why your video is limited to 640x480.  In order to
get beyond that requires one of 2 things.

1) Your laptop vendor to fix their broken BIOS and release a flash update
   for it for you to apply.


2) Intel to release the detailed specifications on how to program the
   chipset to provide more RAM to the video controller, so that someone
   can add this code which should be in your BIOS to the XFree86 video
   driver to workaround the broken BIOS problem.
Comment 2 Mike A. Harris 2002-07-27 14:27:43 EDT

*** This bug has been marked as a duplicate of 65661 ***

Note You need to log in before you can comment on or make changes to this bug.