Bug 69978 - Radeon failure with old VGA monitor
Radeon failure with old VGA monitor
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks: 79579 82776
  Show dependency treegraph
 
Reported: 2002-07-27 13:27 EDT by Alan Cox
Modified: 2007-04-18 12:44 EDT (History)
1 user (show)

See Also:
Fixed In Version: 4.2.1-20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-26 00:57:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log file (18.31 KB, text/plain)
2002-07-27 18:07 EDT, Alan Cox
no flags Details
XF86Config-4 (1.84 KB, text/plain)
2002-07-27 18:07 EDT, Alan Cox
no flags Details

  None (edit)
Description Alan Cox 2002-07-27 13:27:31 EDT
On an ATI radeon VE supplied with the Intel i860/supermicro boards starting
XFree86 fails with the message "No monitor detected!!!". There is a standard
VGA (ancient) monitor attached to the system.

Option "CrtScreen" True 

seems not to help
Comment 1 Alan Cox 2002-07-27 18:07:02 EDT
Created attachment 67366 [details]
Log file
Comment 2 Alan Cox 2002-07-27 18:07:40 EDT
Created attachment 67367 [details]
XF86Config-4
Comment 3 Mike A. Harris 2002-07-29 18:49:48 EDT
After we examined the sources, etc. I figured I'd write ATI to see if they've
got any ideas here.  A config file option might be the best way to go.

Hui, any thoughts?
Comment 4 Mike A. Harris 2002-08-06 01:31:58 EDT
Date: Tue, 30 Jul 2002 09:23:06 -0400
From: Hui Yu <hyu@ati.com>
To: Mike A. Harris <mharris@redhat.com>
Cc: alan@redhat.com
Content-Type: multipart/alternative;
        boundary="--=_NextPart_ST_09_22_03_Tuesday_July_30_2002_19488"
Subject: RE: Radeon VE not detecting ancient fixed freq VGA monitor
Parts/Attachments:
   1 Shown    43 lines  Text
   2   OK    ~81 lines  Text
----------------------------------------
 
If I understand correctly, the problem is that the driver quitted with "No
monitor detected!!!" message. If that's the case, it looks like the video
BIOS didn't detect it either (BIOS will use default VGA mode if nothing is
detected). Radeon driver should do the same thing too. Try this:
search for "No monitor detected" in radeon_driver.c, replace the line
followed (return FALSE;) with info->DisplayType = MT_CRT. Then the driver
will try to bring it up to standard 640x480 VGA mode if no sync range given.
Not sure how things will work out with a mono VGA.
A reminder: it's not safe to connect this old monitor with another monitor
on a different head. You might get it killed if you do so.
 
Hui
Comment 5 Mike A. Harris 2002-08-06 01:47:43 EDT
I think it would be plausible to add this code bit to the driver
disabled by default, but enableable via a config file option.
Comment 6 Alan Cox 2002-08-06 07:47:15 EDT
I get default vga mode text on the monitor. That would make sense.
Comment 7 Alan Cox 2003-02-02 10:20:00 EST
This is much worse in phobe2. The installer picks the native driver the screen
flashes several
times and the machine hangs dead.

Comment 9 Mike A. Harris 2003-02-20 00:41:31 EST
I implemented a new Radeon driver config file option "ForceLegacyCRT" to
implement this change, which defaults to off.

It's in XFree86-4.2.99.902-ati-radeon-vga-alan.patch in my 
XFree86-4.2.99.902-20030218.1 build, but is untested and requires testing
on regular Radeon setups to ensure no regressions, as well as on your
VGA mono.  If it works I'll leave it in for our final release.  Please give
feedback ASAP.

TIA
Comment 10 Mike A. Harris 2003-02-21 09:10:36 EST
XFree86-4.2.1-11.3 has this backported now, so you can test out the
new ForceLegacyCRT option.  It's in the internal errata candidate
tree for RHL 8.0.
Comment 11 Mike A. Harris 2003-02-21 15:34:05 EST
Changing bug state to MODIFIED pending testing and final resolution.  Please
change to RAWHIDE if confirmed fixed, or ASSIGNED if the new option fails.
Comment 12 Mike A. Harris 2003-05-26 00:57:54 EDT
Alan has indicated via email that this option works in rawhide X packages.
Since the similar patch is in 4.2.1 errata, closing as ERRATA.

Note You need to log in before you can comment on or make changes to this bug.