Bug 699886 - virt-install fails with ERROR Unable to create cgroup for $domain: No such device or address
virt-install fails with ERROR Unable to create cgroup for $domain: No such...
Status: CLOSED DUPLICATE of bug 678555
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
15
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-26 16:13 EDT by Javier Ramirez
Modified: 2011-04-27 09:01 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-27 09:01:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Javier Ramirez 2011-04-26 16:13:39 EDT
Description of problem:

Can not initate a virtual machine installation using virt-install

Version-Release number of selected component (if applicable):

Distribution:

Fedora release 15 (Lovelock)

Kernel:

Linux sombrerorojo 2.6.38.2-9.fc15.x86_64 #1 SMP Wed Mar 30 16:55:57 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Packages:

python-virtinst-0.500.6-2.fc15.noarch
libvirt-client-0.8.8-4.fc15.x86_64
libvirt-0.8.8-4.fc15.x86_64
libvirt-python-0.8.8-4.fc15.x86_64

How reproducible:
Always

Steps to Reproduce:
1. virt-install --name Centos56 --ram 512 --disk /var/lib/libvirt/images/Centos56.img,size=10 --cdrom /home/jramirez/Downloads/isos/CentOS-5.6-x86_64-netinstall.iso

  
Actual results:
Fail with the following error:

Starting install...
ERROR    Unable to create cgroup for Centos56: No such device or address
Domain installation does not appear to have been successful.
If it was, you can restart your domain by running:
  virsh --connect qemu:///system start XP
otherwise, please restart your installation.


Expected results:

virt-install to initiate the installation

Additional info:
Comment 1 Javier Ramirez 2011-04-26 16:20:09 EDT
Hi,

Actually I discovered that restarting libvirtd solves the issue, so probably is related to: https://bugzilla.redhat.com/show_bug.cgi?id=666130

Regards.
Comment 2 Cole Robinson 2011-04-27 09:01:25 EDT

*** This bug has been marked as a duplicate of bug 678555 ***

Note You need to log in before you can comment on or make changes to this bug.