Bug 699896 - AVX code generation is broken in LLVM 2.8
AVX code generation is broken in LLVM 2.8
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: llvm (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F15Blocker/F15FinalBlocker 699905
  Show dependency treegraph
 
Reported: 2011-04-26 16:47 EDT by Adam Jackson
Modified: 2011-05-03 00:41 EDT (History)
4 users (show)

See Also:
Fixed In Version: llvm-2.8-11.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 699905 (view as bug list)
Environment:
Last Closed: 2011-05-03 00:41:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adam Jackson 2011-04-26 16:47:42 EDT
Description of problem:

What it says on the box.  This is known upstream (though not in the release notes), and it makes the Mesa software renderer explode when used on Sandybridge CPUs.

Simplest fix for F15 is to disable AVX code generation.  I have a patch for this.

Version-Release number of selected component (if applicable):

2.8-10.fc15
Comment 1 Adam Jackson 2011-04-26 16:59:52 EDT
Upstream bug reference, for the curious:

http://llvm.org/bugs/show_bug.cgi?id=9508
Comment 2 Fedora Update System 2011-04-26 17:28:01 EDT
llvm-2.8-11.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/llvm-2.8-11.fc15
Comment 3 Fedora Update System 2011-04-26 22:27:39 EDT
Package llvm-2.8-11.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing llvm-2.8-11.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/llvm-2.8-11.fc15
then log in and leave karma (feedback).
Comment 4 Adam Williamson 2011-04-29 14:09:40 EDT
Discussed at the 2011-04-29 blocker review meeting. Accepted as a blocker under criterion "# Following on from the previous criterion, after firstboot is completed and on subsequent boots, a system installed according to any of the above criteria (or the appropriate Beta or Final criteria, when applying this criterion to those releases) must boot to a working graphical environment without unintended user intervention. This includes correctly accessing any encrypted partitions when the correct passphrase is supplied "; this could cause catastrophic desktop failure in certain circumstances.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Fedora Update System 2011-05-03 00:41:21 EDT
llvm-2.8-11.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.