Bug 69991 - Self-test of glibc fails on i586 build
Summary: Self-test of glibc fails on i586 build
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 7.3
Hardware: i586 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-28 04:19 UTC by Steve Snyder
Modified: 2016-11-24 15:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-28 04:19:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steve Snyder 2002-07-28 04:19:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020623

Description of problem:
After a successful build of glibc-2.2.5-37 binary RPM on an i586 system, running
the glibc self-test suite causes a failure of the "tst-rndseek" test to complete
successfully.

Version-Release number of selected component (if applicable):
glibc-2.2.5-37.src.rpm

How reproducible:
Always

Steps to Reproduce:
1.Unpack glibc-2.2.5-37.src.rpm
2.Comment-out the running of the "make check" in the glibc.spec file
3.Run: rpm -bb /usr/src/redhat/SPECS/glibc.spec
4.Note successfull build of binary RPMs.
5.Go to /usr/src/redhat/BUILD/glibc/build-i386-linux and run "make check".
6.You see the GBxxxxx locale test fail (this happens of all platforms).  Run
"make check" again to resume self-test.  No other errors seen.
[The above is our baseline.  Now on to the bug report.]
7.Run: rpm -bb --target i586-redhat-linux /usr/src/redhat/SPECS/glibc.spec
8.Again the build of the binary RPMs is OK.
9.Go to /usr/src/redhat/BUILD/glibc/build-i586-linux and run "make check". 
10. As before, the GBxxxx locate test will fail.  Restart again with "make check".
11.Now the self-test suite will stop on the failure of test "tst-rndseek".  The
reported error is that the test timed-out.


Actual Results:  Running the self-test shows the GBxxxx locale test to fail on
i386, i586, and i686 system.  It is only on i586 build, though, that the
tst-rndseek test fails.


Expected Results:  Running the self test on an i586 build should not show any
more errors than on any other platform.

Additional info:

1. The i586 build was done on an i586 system.  (The i386 and i686 builds
referenced above were done on K6-III and i686 systems, respectively.)

2. The compiler used for the build was gcc-2.96-112, binutils were
binutils-2.11.93.0.2-11.  These tools were used on all builds referenced in this
bug report.

3.If the self-test is not commented-out in the spec file, the error(s) are
ignored and the build completes successfully.  Certainly the GBxxxx failure
occures and is ignored.  I have not had the occasion to notice any other errors
masked by the forgiving launch of the self-tests from the spec file.

Comment 1 Jakub Jelinek 2002-08-16 08:19:54 UTC
As for the GBxxx failure, that's because in 7.3 glibc GB18030 iconv module
was modified to follow Chinesse government request to handle even unassigned
Unicode points but charmaps/GB18030 was not updated. You can check out latest
rawhide glibc where the test works just fine.

As for tst-rndseek, if it timed out, it most probably means just that the
machine is too slow to run 10000 fseek+2xfgetc calls in less than 2 seconds.
You can try to run the test by hand with --direct option to see if it
actually finishes (elf/ld.so --library-path . stdio-common/tst-rndseek --direct).


Note You need to log in before you can comment on or make changes to this bug.