Bug 69995 - nice -n 8 produces erroneous result in tcsh
Summary: nice -n 8 produces erroneous result in tcsh
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sh-utils   
(Show other bugs)
Version: 7.2
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: wdovlrrw
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-28 10:50 UTC by Scott R. Godin
Modified: 2007-04-18 16:44 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-28 10:50:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Scott R. Godin 2002-07-28 10:50:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020509

Description of problem:
 nice -n 8 /usr/bin/mrtg /etc/mrtg/mrtg.cfg

nice: Badly formed number.

nice --help

nice: Badly formed number.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1./bin/tcsh
2.nice --help
 -or- 
3.nice -n 8 /usr/bin/mrtg /etc/mrtg/mrtg.cfg

	

Actual Results:  nice: Badly formed number.


Expected Results:  should have adjusted priority accordingly

Additional info:

works as expected under bash/sh/zsh

not sure whether this is tcsh specific or not, renice works normally under tcsh.
I use tcsh 100% of the time, by personal preference, and this is the first
instance of finding a stock command that doesn't work as expected in 6 months of
daily usage of 7.2

Comment 1 Scott R. Godin 2002-07-28 11:07:25 UTC
bleh, as it turns out, nice is also a tcsh builtin and this wasn't /bin/nice
misbehaving, as further investigation discovered. *sigh* ah well, one less thing
to worry about.


Note You need to log in before you can comment on or make changes to this bug.