Bug 69998 - DISK DRUID and Parted giving wrong information
DISK DRUID and Parted giving wrong information
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: parted (Show other bugs)
7.3
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
http://www7.brinkster.com/rohit79/fdi...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-28 08:07 EDT by Need Real Name
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-04 08:56:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-07-28 08:07:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 95)

Description of problem:
I have two hard disks primary master and primary slave on the machine. I was 
running (dual boot) windows and mandrake linux 8.1 rc2 previously, this time i 
tried installing redhat 7.3 vallhala on top of the mandrake partition as it's a 
spare machine.

while installing i found out that disk druid wrongly shows /dev/hda1 as swap 
while if i switch back to console and do fdisk /tmp/hda it shows the /dev/hda1 
as windows fat with the system ID b... even if i fdisk from mandrake it shows 
the same as shown in the pic.

anyways if i let it go without reformatting /dev/hda1 it ended up giving me the 
error after choosin the packages

error enabling swap device hda1:
Invalid argument
This most likely means this swap partition has not been initialized.


i do not want to loose windows partition. i tried again resinstalling mandrake 
and it worked without any glitch.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.it reproduces every time i insert the cd there is nothing typical i can  
write in here ... i am unable to install redhat in the first place itself, 
though other distro is working perfectly.
2.
3.
	

Additional info:

besides the fdisk here is the parted information 

hda

Disk geometry for /dev/ide/host0/bus0/target0/lun0/disc: 0.000-3079.125
megabytes
Disk label type: msdos
Minor    Start       End     Type      Filesystem  Flags
1          0.031   2035.687  primary   linux-swap  boot
2       2035.688   3079.125  extended
5       2035.718   2067.187  logical   ext2
6       2067.218   3079.125  logical   ext2


hdb

Disk geometry for /dev/ide/host0/bus0/target1/lun0/disc: 0.000-4112.226
megabytes
Disk label type: msdos
Minor    Start       End     Type      Filesystem  Flags
1          0.031    522.795  primary   linux-swap  boot
2        522.795   4112.226  extended
5        522.826   1594.687  logical   ext3
6       1594.718   4112.226  logical   ext3

also take a look at this http://www7.brinkster.com/rohit79/fdisk.png
Comment 1 Matt Wilson 2002-11-20 12:56:18 EST
/dev/hda1 probably has both a valid FAT signature and a valid swap partition
signature.
Comment 2 Jeremy Katz 2004-06-25 14:34:07 EDT
Is this better with newer releases (ie, Fedora Core 1 or 2)?
Comment 3 Jeremy Katz 2004-11-04 08:56:57 EST
Closing due to inactivity.  Please reopen this bug if you have further
information to add to the report.

Note You need to log in before you can comment on or make changes to this bug.