Bug 70008 - +adjoin function in convert doesn't work
+adjoin function in convert doesn't work
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: ImageMagick (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-28 16:12 EDT by Kevin Battaile
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-14 13:54:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Battaile 2002-07-28 16:12:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
When converting a series of jpeg files using the command 'convert +adjoin
frame_*.jpeg frame_%02d.pnm' one frame is produced and the program exits. This
seems to be a problem with the ImageMagick-5.4.3.11-1 distribution as the same
command with convert from ImageMagick-5.3.8-3 included in  RedHat-7.2 seems to
work fine.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Create series of jpeg files.
2.Issue 'convert +adjoin frame_*.jpeg frame_%02d.pnm' (the frame_ is the prefix
when I make the images with the * being an increase in number).

	

Actual Results:  One file is created.

Expected Results:  One file for each jpeg is created, ie, if I have 20 jpeg
files, 10 pnm files should be created.

Additional info:For me, this problem essentially renders convert unusable.
Comment 1 Kevin Battaile 2002-07-29 09:36:18 EDT
Under expected results, that should be 20 pnm files made from 20 jpegs. Sorry
about the confusion if there was any.
Comment 2 Matthias Clasen 2005-09-14 13:54:54 EDT
Please try to reproduce this against a supported release and reopen if you can.

Note You need to log in before you can comment on or make changes to this bug.