Bug 700183 - [abrt] rakarrack-0.6.1-2.fc13: AnalogFilter::setfreq: Process /usr/bin/rakarrack was killed by signal 4 (SIGILL)
Summary: [abrt] rakarrack-0.6.1-2.fc13: AnalogFilter::setfreq: Process /usr/bin/rakarr...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rakarrack
Version: 13
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Timms
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:dbe71955ecaf701ab8d96e7bfc5...
: 657035 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-27 17:07 UTC by David Ford
Modified: 2011-05-25 03:13 UTC (History)
3 users (show)

Fixed In Version: rakarrack-0.6.1-4.git47245c3.fc14
Doc Type: Bug Fix
Doc Text:
SIGILL = illegal instruction.
Clone Of:
Environment:
Last Closed: 2011-05-25 02:51:00 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (40.39 KB, text/plain)
2011-04-27 17:07 UTC, David Ford
no flags Details
diff from an F14 start(success) to Davids F13 start (exception). (2.36 KB, text/plain)
2011-04-28 14:27 UTC, David Timms
no flags Details

Description David Ford 2011-04-27 17:07:49 UTC
abrt version: 1.1.14
architecture: i686
Attached file: backtrace
cmdline: rakarrack
comment: click in menu
component: rakarrack
crash_function: AnalogFilter::setfreq
executable: /usr/bin/rakarrack
kernel: 2.6.34.8-68.fc13.i686.PAE
package: rakarrack-0.6.1-2.fc13
rating: 4
reason: Process /usr/bin/rakarrack was killed by signal 4 (SIGILL)
release: Fedora release 13 (Goddard)
time: 1303923079
uid: 500

How to reproduce
-----
1.tried to start 
2.
3.

Comment 1 David Ford 2011-04-27 17:07:52 UTC
Created attachment 495290 [details]
File: backtrace

Comment 2 David Timms 2011-04-28 10:24:48 UTC
(In reply to comment #0)
> How to reproduce
> -----
> 1.tried to start 

Hi, it's not clear what was the process leading up to the crash was:

- did the rakarrack gui start up and display ?

- what preset is showing ?

- had you switched FX On ?

- which menu and item did you click ?

Comment 3 David Timms 2011-04-28 10:50:42 UTC
*** Bug 657035 has been marked as a duplicate of this bug. ***

Comment 4 David Ford 2011-04-28 11:15:29 UTC
Hi David
With Jack running, I clicked on the menu entry and nothing happened.

I've just tried to type rakarrack on the command line and I got this :-
(but I forgot to start jack first)

[david@thinkpad ~]$ rakarrack

rakarrack 0.6.1 - Copyright (c) Josep Andreu - Ryan Billing - Douglas McClendon - Arnout Engelen
Try 'rakarrack --help' for command-line options.
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jackdmp 1.9.5
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2009 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
could not open driver .so '/usr/lib/jack/jack_firewire.so': libffado.so.2: cannot open shared object file: No such file or directory
could not open component .so '/usr/lib/jack/jack_firewire.so': libffado.so.2: cannot open shared object file: No such file or directory
JACK server starting in realtime mode with priority 60
audio_reservation_init
Acquire audio card Audio0
creating alsa driver ... hw:0|hw:0|1024|2|48000|0|0|nomon|swmeter|-|32bit
Using ALSA driver ICH running on card 0 - Intel 82801CA-ICH3 with CS4299 at irq 11
configuring for 48000Hz, period = 1024 frames (21.3 ms), buffer = 2 periods
ALSA: final selected sample format for capture: 16bit little-endian
ALSA: use 2 periods for capture
ALSA: final selected sample format for playback: 16bit little-endian
ALSA: use 2 periods for playback
Using port names patch v0.1 (07.04.2010)
Illegal instruction (core dumped)
[david@thinkpad ~]$ JackTemporaryException : now quits...
jack main caught signal 2
JackServer::ClientKill ref = 2 cannot be closed
Released audio card Audio0
audio_reservation_finish
[david@thinkpad ~]$

OK I've just started jack - I'll try again. :-

(With jack running)
[david@thinkpad ~]$ rakarrack

rakarrack 0.6.1 - Copyright (c) Josep Andreu - Ryan Billing - Douglas McClendon - Arnout Engelen
Try 'rakarrack --help' for command-line options.
Illegal instruction (core dumped)
[david@thinkpad ~]$ 

I also downloaded gnuguitarinux-1.0.iso (a 'Live' mini distro) and ran rakarrack on that - It gave me the same (Illegal instruction) error.

I've just run rakarrack --help with exactly the same result - abrt has complained - I'll report that although it will probably be the same.

Just in case it helps :-

This is running on:
an IBM Thinkpad T23
PIII cpu 1.13Ghz (32 bit obviously)
1 GB ram
Using the onboard sound chip

Anything else?

Just to answer your question directly :-
Menu item: Applications -> Sound and Video -> Rakarrack
Rakarrack did not start up
No GUI displayed 

David.

Comment 5 David Ford 2011-04-28 11:46:25 UTC
Package: rakarrack-0.6.1-2.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1started jackran rakarrack
2ran rakarrack --help on the command line
3.


Comment
-----
.ran rakarrack --help on the command line

Comment 6 David Timms 2011-04-28 14:27:46 UTC
Created attachment 495556 [details]
diff from an F14 start(success) to Davids F13 start (exception).

(In reply to comment #4)
> With Jack running, I clicked on the menu entry and nothing happened.
...
> Menu item: Applications -> Sound and Video -> Rakarrack
> Rakarrack did not start up
> No GUI displayed 

OK, I misunderstood. I took it to be that it started and then you attempted to click one of rakarrack's menu items, and that's where it failed.

I think it would be good to test Alsa driver with your hardware with another piece of software: can you try audacity: (actually for F14 but might be OK):
http://koji.fedoraproject.org/koji/buildinfo?buildID=241109

Comment 7 David Timms 2011-04-28 14:32:22 UTC
Note: if jackd isn't running, rakarrack starts it anyhow.

Comment 8 David Ford 2011-04-28 16:06:38 UTC
Hi David

Audacity ® 1.3.12-beta (Unicode) - NB for FC13.
Audacity - Play and Record - works fine - see below for details

Other stuff that works 

Tested OK without jack - with ALSA + pulseaudio:-
Rhythmbox
Movieplayer (totem)
MPlayer
VLC
Timidity++
Hydrogen

Tested OK with jack no pulseaudio :-
Ardour - play and record
Qmmp
ZynAddSubFX
Timidity++
Hydrogen

Hope this helps - let me know if you want me to try anything else

David

--------------------------------------*
Audacity Build Information

File Format Support
libmad
(MP3 Importing)
Enabled
libvorbis
(Ogg Vorbis Import and Export)
Enabled
libid3tag
(ID3 tag support)
Enabled
libflac
(FLAC import and export)
Enabled
libtwolame
(MP2 export)
Disabled
QuickTime
(Import via QuickTime)
Disabled
Core Libraries
libsamplerate
(Sample rate conversion)
Enabled
PortAudio
(Audio playback and recording)
v19
wxWidgets 2.8.11
(Unicode)
Features
Nyquist
(Plug-in support)
Enabled
LADSPA
(Plug-in support)
Enabled
Vamp
(Plug-in support)
Enabled
Audio Units
(Plug-in support)
Disabled
PortMixer
(Sound card mixer support)
Enabled
SoundTouch
(Pitch and Tempo Change support)
Enabled
Build Information
Program build date: 
Oct 30 2010
Build type:
Release build
Installation Prefix: 
/usr
Settings folder: 
/home/david/.audacity-data

Comment 9 David Timms 2011-04-28 22:25:41 UTC
Can you please:

uname -a
rpm -qa kernel\* \*alsa\*

cat /proc/cpuinfo > cpuinfo.txt
  and attach cpuinfo.txt as an attachment to this bug.

I suspect that the compiler is optimizing for enhanced CPU functionality, and your CPU doesn't have the needed functionality.

Comment 10 David Timms 2011-04-28 22:39:09 UTC
Hi again, I've built the current git release for f13,i686:
http://members.iinet.net.au/~timmsy/rakarrack/
  (git versions)
It would be good to install the package and debug info, and then run from the command line to check whether anything changes.

If it doesn't work, rebuild the .srpm on your machine, install that package, and see how you go ?

Comment 11 David Ford 2011-04-28 22:56:55 UTC
Hi David
uname -a
Linux thinkpad 2.6.34.8-68.fc13.i686.PAE #1 SMP Thu Feb 17 14:54:10 UTC 2011 i686 i686 i386 GNU/Linux

rpm -qa kernel\* \*alsa\*
kernel-headers-2.6.34.8-68.fc13.i686
alsamixergui-0.9.0-0.9.rc2.fc12.i686
kernel-PAE-2.6.34.7-66.fc13.i686
kernel-PAE-2.6.34.8-68.fc13.i686
report-config-localsave-0.20-0.fc13.i686
alsa-utils-1.0.23-3.fc13.i686
alsa-plugins-pulseaudio-1.0.22-1.fc13.i686
alsa-lib-1.0.23-1.fc13.i686
report-plugin-localsave-0.20-0.fc13.i686
kernel-PAE-2.6.34.7-63.fc13.i686

cpuinfo.txt
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 11
model name	: Mobile Intel(R) Pentium(R) III CPU - M  1133MHz
stepping	: 4
cpu MHz		: 1130.500
cache size	: 512 KB
fdiv_bug	: no
hlt_bug		: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 2
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 mtrr pge mca cmov pse36 mmx fxsr sse up
bogomips	: 2265.18
clflush size	: 32
cache_alignment	: 32
address sizes	: 36 bits physical, 32 bits virtual
power management:

David
PS
I've downloaded the files - I'll install them tomorrow and let you know what happens - not sure how to rebuild the srpm but I'll google around if I need to - after I've tried the new rpm.

Thanks for your help.

Comment 12 David Ford 2011-04-29 12:01:03 UTC
[david@thinkpad ~]$ rakarrack

rakarrack 0.6.2 - Copyright (c) Josep Andreu - Ryan Billing - Douglas McClendon - Arnout Engelen
Try 'rakarrack --help' for command-line options.
Illegal instruction (core dumped)

with the new rpm - I'll see if I can find out how to do the bit with the src rmp

David

Comment 13 David Timms 2011-04-29 13:52:24 UTC
hints:

yum install gcc-c++ yum-utils rpm-build

install devel build requires:
yum-builddep /the/source.src.rpm

rpmbuild --rebuild /the/source.src.rpm

Comment 14 David Ford 2011-04-29 14:46:12 UTC
Thanks for the hints David - I found a very nice rpmbuild HOWTO on Fedora

The good news is that having waded through all that stuff - I now have a working copy of rakarrack - fantastic! And it was worth the effort - it works great!

Tested both from the command line without starting jack - no problems
and from the 'Sound and Video' menu with jack running first.

Are any of these rpms I've built any use to anyone else - or can I just delete them now I've installed them?

(The only thing that's stopping me from upgrading to FC14 is that there's only 300Mb left in /home and I need to do a bit of boring housekeeping - so I'd like to reclaim any space I can).

Thanks again for all your help!

David

Comment 15 David Timms 2011-05-11 10:11:30 UTC
The build had included instructions not available on CPU = PentiumIII. This is due to the configure detecting the CPU of the machine compiling the code.

The package spec now enables only SSE on x86 and allows SSE2 on x86_64. This should provide simple coverage for different CPU archs. Build now available in rawhide.

Comment 16 David Timms 2011-05-11 10:11:31 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
SIGILL = illegal instruction.

Comment 17 Fedora Update System 2011-05-11 13:24:26 UTC
rakarrack-0.6.1-4.git47245c3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/rakarrack-0.6.1-4.git47245c3.fc15

Comment 18 Fedora Update System 2011-05-11 13:25:40 UTC
rakarrack-0.6.1-4.git47245c3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/rakarrack-0.6.1-4.git47245c3.fc14

Comment 19 Fedora Update System 2011-05-11 13:26:49 UTC
rakarrack-0.6.1-4.git47245c3.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/rakarrack-0.6.1-4.git47245c3.fc13

Comment 20 Fedora Update System 2011-05-13 23:06:46 UTC
Package rakarrack-0.6.1-4.git47245c3.fc13:
* should fix your issue,
* was pushed to the Fedora 13 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rakarrack-0.6.1-4.git47245c3.fc13'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/rakarrack-0.6.1-4.git47245c3.fc13
then log in and leave karma (feedback).

Comment 21 David Ford 2011-05-15 11:39:12 UTC
Hi David
Removed the Rakarrack that I built from source.

yum update --enablerepo=updates-testing . . . gave me the message :-
Package(s) rakarrack-0.6.1-4.git47245c3.fc13 available, but not installed.
So I used :
yum install --enablerepo=updates-testing . . . that installed fine

Not done an extensive test - the neighbours you know - but clicked a few buttons and presets and it seems to work fine.

Left an 'It works for me' at fedoraproject.org

You're not looking after Creox too are you? They seem to have a similar bug.
I'll log a new bug for it.

Thanks for all your help in getting it working.

David

Comment 22 Fedora Update System 2011-05-25 02:50:43 UTC
rakarrack-0.6.1-4.git47245c3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 23 Fedora Update System 2011-05-25 02:55:35 UTC
rakarrack-0.6.1-4.git47245c3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 24 Fedora Update System 2011-05-25 03:13:32 UTC
rakarrack-0.6.1-4.git47245c3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.