Bug 70022 - X hangs machine
X hangs machine
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-29 03:02 EDT by Mikkel Lauritsen
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 04:51:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X configuration (1.90 KB, text/plain)
2002-08-04 06:38 EDT, Mikkel Lauritsen
no flags Details
/var/log/messages (14.43 KB, text/plain)
2002-08-04 06:39 EDT, Mikkel Lauritsen
no flags Details
X log (9.27 KB, text/plain)
2002-08-04 06:40 EDT, Mikkel Lauritsen
no flags Details

  None (edit)
Description Mikkel Lauritsen 2002-07-29 03:02:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020721

Description of problem:
When starting X the X server apparently crashes and takes the entire machine
down. I haven't been able to record any logging information so far or even see
any of the console messages from the server.

The configuration has been autodetected by Xconfigurator and is apparently
correct since using the 'nvidia' driver from nVidia instead of the default 'nv'
driver works perfectly.

How reproducible:
Always

Steps to Reproduce:
1. Start X by any means - going to runlevel 5 or by running startx or Xtest all
have the same result.

Actual Results:  The machine hangs completely with a black screen; it only
responds to a hard reset.

Additional info:

Hardware: Athlon XP1800+ on Asus A7N266-VM, 1GB ram. Builtin GeForce 2 MX
graphics, Viewsonic GT775 monitor.
Comment 1 Mike A. Harris 2002-07-29 17:26:05 EDT
Attach your X config file and X server log.
Comment 2 Need Real Name 2002-07-29 17:27:52 EDT
I have also experienced this problem upgrading from 7.2 to 7.3.  Using the same settings from 7.2 I get black screen and system appears to hang.
During installation, the test screen comes up properly, but after install, using Xconfigurator gives the black screen/hang symptom.  I am using a 
CTX1451 monitor and Trident TGUI9660 video card.
Comment 3 Mike A. Harris 2002-07-29 17:39:24 EDT
Also attach your /var/log/messages file please.
Comment 4 Mike A. Harris 2002-07-29 17:40:39 EDT
Trident problems would be unrelated to Nvidia problems.  Please file
a separate bug report, but only after testing our latest beta (Limbo),
since there are known 9660 issues which have been dealt with in limbo.

Comment 5 Mikkel Lauritsen 2002-08-04 06:38:41 EDT
Created attachment 68804 [details]
X configuration
Comment 6 Mikkel Lauritsen 2002-08-04 06:39:49 EDT
Created attachment 68805 [details]
/var/log/messages
Comment 7 Mikkel Lauritsen 2002-08-04 06:40:40 EDT
Created attachment 68806 [details]
X log
Comment 8 Mike A. Harris 2002-12-15 04:51:00 EST
A tester is unable to reproduce any problem using rawhide XFree86 and
rawhide kernel.  Closing bug as fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.