Bug 700252 - Unable to configure Bugzilla plugin
Unable to configure Bugzilla plugin
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jiri Moskovcak
Fedora Extras Quality Assurance
abrt_hash:9bcca887c3c5bb38f2e27d2c2b4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-27 17:47 EDT by Tim Waugh
Modified: 2015-02-01 17:53 EST (History)
9 users (show)

See Also:
Fixed In Version: abrt-2.0.6-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-21 17:51:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot showing "Select reporter" dialog and BZ name and pw dialog (148.26 KB, image/png)
2011-04-28 07:55 EDT, Steve Tyler
no flags Details
Screenshot-Event Configuration.png (85.74 KB, image/png)
2011-04-28 08:22 EDT, Tim Waugh
no flags Details

  None (edit)
Description Tim Waugh 2011-04-27 17:47:15 EDT
Description of problem:
When reporting a bug I am not given the opportunity to enter a login/password.

Version-Release number of selected component (if applicable):
abrt-plugin-bugzilla-2.0.1-2.fc15.x86_64
abrt-addon-kerneloops-2.0.1-2.fc15.x86_64
abrt-2.0.1-2.fc15.x86_64
abrt-debuginfo-2.0.1-2.fc15.x86_64
abrt-libs-2.0.1-2.fc15.x86_64
abrt-desktop-2.0.1-2.fc15.x86_64
abrt-addon-python-2.0.1-2.fc15.x86_64
abrt-gui-2.0.1-2.fc15.x86_64
abrt-addon-ccpp-2.0.1-2.fc15.x86_64
abrt-plugin-logger-2.0.1-2.fc15.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Open abrt
2.Click on an unreported crash and click Open
3.Click Forward
4.Enter a description of what you did and click Forward
5.Select 'Bugzilla' and click Configure Events
6.In the Event Configuration dialog, select Bugzilla
7.Close the dialog.
8.Click Forward.
9.Select 'I agree...' and click Forward.
10.Click Forward.
  
Actual results:
At step 6, only the Close button is sensitive.
At step 10, I get:

Reporting finished with exit code 1
Empty login or password, please check your configuration
Comment 1 Steve Tyler 2011-04-28 07:14:58 EDT
Did you click "Configure Event" after selecting "Bugzilla"?
(That's where you set your BZ user name and password.)
Comment 2 Steve Tyler 2011-04-28 07:22:38 EDT
(In reply to comment #0)
...
> Reporting finished with exit code 1
> Empty login or password, please check your configuration

Now I see what you mean.
abrt-gui knows it doesn't have your BZ credentials, but it doesn't prompt you for them.
Comment 3 Steve Tyler 2011-04-28 07:41:42 EDT
I get an alert in the "Select reporter" dialog after checking Bugzilla:
"Wrong settings detected for Bugzilla, reporting will probably fail if you continue with the current configuration. Close"

abrt-2.0.1-2.fc15.i686
Comment 4 Steve Tyler 2011-04-28 07:55:34 EDT
Created attachment 495518 [details]
screenshot showing "Select reporter" dialog and BZ name and pw dialog
Comment 5 Tim Waugh 2011-04-28 08:22:28 EDT
Created attachment 495523 [details]
Screenshot-Event Configuration.png

No, the "Configure Event" button is not sensitive.
Comment 6 Steve Tyler 2011-04-28 08:41:38 EDT
(In reply to comment #5)
> Created attachment 495523 [details]
> Screenshot-Event Configuration.png
> 
> No, the "Configure Event" button is not sensitive.

OK, thanks. I can't reproduce this.

Selecting "Local GNU Debugger" desensitizes the "Configure Event" button, but the button is sensitive when I select any of the other items.

What do you have for 'libreport*'?
(abrt-gui spawns bug-reporting-wizard)

$ rpm -qa 'abrt*' 'libreport*' | sort
abrt-2.0.1-2.fc15.x86_64
abrt-addon-ccpp-2.0.1-2.fc15.x86_64
abrt-addon-kerneloops-2.0.1-2.fc15.x86_64
abrt-addon-python-2.0.1-2.fc15.x86_64
abrt-cli-2.0.1-2.fc15.x86_64
abrt-desktop-2.0.1-2.fc15.x86_64
abrt-gui-2.0.1-2.fc15.x86_64
abrt-libs-2.0.1-2.fc15.x86_64
abrt-plugin-bugzilla-2.0.1-2.fc15.x86_64
abrt-plugin-logger-2.0.1-2.fc15.x86_64
libreport-2.0.1-2.fc15.x86_64
libreport-gtk-2.0.1-2.fc15.x86_64
Comment 7 Tim Waugh 2011-04-28 08:52:55 EDT
libreport-2.0.1-2.fc15.x86_64
libreport-gtk-2.0.0-4.fc15.x86_64

This is because I'd done: yum --enablerepo=updates-testing update 'abrt*' and it had only pulled in libreport-2.0.1-2.fc15.

Updating libreport-gtk to 2.0.1-2.fc15 fixes the problem.

Perhaps libreport-gtk should have an explicit version dependency on the main libreport package.
Comment 8 Jiri Moskovcak 2011-04-28 10:38:00 EDT
(In reply to comment #7)
> Perhaps libreport-gtk should have an explicit version dependency on the main
> libreport package.

- yes, you're right, going to fix this.
Comment 9 Fedora Update System 2011-11-05 14:58:41 EDT
abrt-2.0.6-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/abrt-2.0.6-1.fc16
Comment 10 Fedora Update System 2011-11-06 18:56:02 EST
Package abrt-2.0.6-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.6-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15513
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2011-11-21 17:51:57 EST
abrt-2.0.6-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.