Bug 70036 - UTF8 command line redraws slow/consume too much CPU
UTF8 command line redraws slow/consume too much CPU
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: readline (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-29 11:38 EDT by Chip Turner
Modified: 2015-01-07 18:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-10 11:04:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chip Turner 2002-07-29 11:38:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020712

Description of problem:
Best seen in bash with LANG=en_US.UTF-8.  Paste arbitrary text into the command
line until it is rather large (> 200-300 characters).  Each additional character
typed or pasted will force a redraw.  This redraw consumes excessive CPU, which
can be seen with top.  Happens in multiple X terminal emulators, seems to be
inside of readline itself.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Paste moderate amounts of data into a bash prompt.

Additional info:
Comment 1 Tim Waugh 2004-12-10 11:04:50 EST
This is fixed now I think.

Note You need to log in before you can comment on or make changes to this bug.