Bug 700455 - Retire ovirt-server package
Summary: Retire ovirt-server package
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ovirt-server
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Scott Seago
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-28 12:55 UTC by Nicola Soranzo
Modified: 2011-07-28 07:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-07-28 07:51:32 UTC


Attachments (Terms of Use)

Description Nicola Soranzo 2011-04-28 12:55:57 UTC
Description of problem:
Since HAL has been deprecated upstream for 3 years, all major distributions are removing it. You can find more details on the proposed Fedora Feature page:

https://fedoraproject.org/wiki/Features/HalRemoval

The hal package has already been deprecated by its maintainer and blocked from composes for rawhide.
Therefore, unless somebody volunteers to maintain hal, the following broken dependencies for your package should be removed:

ovirt-server-installer-0.100-6.fc15.noarch requires hal

Version-Release number of selected component (if applicable):
ovirt-server-0.100-6.fc15

Comment 1 Nicola Soranzo 2011-06-16 10:07:46 UTC
I'm reading now on ovirt website:

https://fedorahosted.org/ovirt/wiki/FAQ

this:

"What's going on with ovirt-server? 

        The server project is not being actively worked on at this time. It is available for adoption however. Please email ovirt-devel if you're interested in adopting over the project.
        Current Status of the project: The server was running on Fedora 13, but rails changes in Fedora 14 and 15 have caused it to not work any longer."

and similarly on the mailing list:

https://www.redhat.com/archives/ovirt-devel/

So I suppose that this bug will never be fixed. I suggest that ovirt-server package should be deprecated by following the procedure:

https://fedoraproject.org/wiki/How_to_remove_a_package_at_end_of_life

Comment 2 Nicola Soranzo 2011-06-24 13:04:04 UTC
Can you please explain why you closed this bug report as WONTFIX while the package is not deprecated for Fedora 16 yet?
There is still the following broken dependency:

ovirt-server-installer-0.100-6.fc15.noarch requires hal

Comment 3 Nicola Soranzo 2011-07-12 10:08:46 UTC
No answer, reopening.

Comment 4 Nicola Soranzo 2011-07-14 15:13:07 UTC
ace package has also been deprecated recently, so now there are 2 additional broken dependencies:

ovirt-server-installer-0.100-6.fc15.noarch requires ace-postgres
ovirt-server-installer-0.100-6.fc15.noarch requires ace

Comment 5 Nicola Soranzo 2011-07-28 07:51:32 UTC
ovirt-server has been deprecated today, closing this bug report.
For reference, this is the ticket to block the package from composes:

https://fedorahosted.org/rel-eng/ticket/4843


Note You need to log in before you can comment on or make changes to this bug.