Bug 700494 - Allow JCA Adapter to use either BURL or ADDR syntax
Summary: Allow JCA Adapter to use either BURL or ADDR syntax
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-jca
Version: Development
Hardware: All
OS: All
unspecified
medium
Target Milestone: 2.1.2
: ---
Assignee: messaging-bugs
QA Contact: MRG Quality Engineering
URL:
Whiteboard:
: 696746 (view as bug list)
Depends On:
Blocks: 735030
TreeView+ depends on / blocked
 
Reported: 2011-04-28 14:16 UTC by Weston M. Price
Modified: 2016-02-22 00:59 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:
Target Upstream Version:


Attachments (Terms of Use)

Description Weston M. Price 2011-04-28 14:16:33 UTC
Description of problem:

Currently the QPID JCA adapter uses the BURL syntax for destination creation. This was introduced in large part to support clients in the field. However, for consistency, an option should be give to use either BURL or ADDR syntax.


Version-Release number of selected component (if applicable):

The effects the current version of the QPID JCA adapter.

How reproducible:
NA

Steps to Reproduce:
NA  

Actual results:
NA

Additional info:
This particularly effects the QpidDestinationProxy and associated classes.

Comment 3 Andrew Stitcher 2011-09-22 13:30:40 UTC
This has been fixed in package qpid-java-jca-0.10-10

Comment 5 Weston M. Price 2011-11-22 14:14:41 UTC
*** Bug 696746 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.