Bug 700547 - rhsm-icon pop up notification appears in a random location
rhsm-icon pop up notification appears in a random location
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 6.2
Assigned To: Bryan Kearney
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-04-28 12:05 EDT by J.C. Molet
Modified: 2013-01-10 05:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:13:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pop up warning (422.21 KB, image/png)
2011-04-28 12:05 EDT, J.C. Molet
no flags Details
warning dialog (439.14 KB, image/png)
2011-05-19 12:20 EDT, J.C. Molet
no flags Details
big icon (191.00 KB, image/png)
2011-05-19 12:27 EDT, J.C. Molet
no flags Details

  None (edit)
Description J.C. Molet 2011-04-28 12:05:56 EDT
Created attachment 495583 [details]
pop up warning

Description of problem:
When receiving a pop up warning from rhsm-icon, the pop up shows up in a random location

Version-Release number of selected component (if applicable):
subscription-manager-0.95.5.8-1.git.6.42d8706.el5
subscription-manager-firstboot-0.95.5.8-1.git.6.42d8706.el5
subscription-manager-gnome-0.95.5.8-1.git.6.42d8706.el5

How reproducible:
??

Steps to Reproduce:
1. Get a rhel 5.7 system with subscription-manager* installed
2. make sure there is a product installed in /etc/pki/products/
3. make sure rhsm-icon is running
4. log into your user
(you can also replicate this with any other action that would prompt this pop up, such as starting subscription-manager-gui, or running rhsm-icon --force-icon=expired -d)
  
Actual results:
The pop up shows up in a random location or doesn't show up at all.

Expected results:
The pop up shows up under the rhsm-icon in the taskbar

Additional info:
See screenshot

Also for interesting results, log into gnome as a different, non root user.  Then as that user open a terminal and 'su -'.   Then run rhsm-icon --force-icon=expired -d.  The icon in the taskbar shows up, but the pop up does not.
Comment 1 spandey 2011-05-18 07:15:18 EDT
Verified using following setup :

subscription-manager-gnome-0.95.5.18-1.git.0.490e92f.el5
subscription-manager-0.95.5.18-1.git.0.490e92f.el5
subscription-manager-firstboot-0.95.5.18-1.git.0.490e92f.el5

Working fine 

Moving defect status from Modified to Verified
Comment 2 J.C. Molet 2011-05-19 12:20:05 EDT
Created attachment 499894 [details]
warning dialog

This appears to be fixed when you run rhsm-icon manually as in the case above.

However, when you log in, and rhsm-icon is spawned as part of your desktop session loading, the pop up is on the opposite side of the icon.  See screenshot.

subscription-manager-gnome-0.95.5.18-1.el5.x86_64 (version found in rhel 5.7 beta)
Comment 3 J.C. Molet 2011-05-19 12:27:15 EDT
Created attachment 499896 [details]
big icon

Also note that in verifying the above, if you start up the icon manually now, the icon is now about twice as big and doesn't fit in the taskbar (see attached).
Comment 4 J.C. Molet 2011-05-19 12:29:33 EDT
(In reply to comment #2)
> Created attachment 499894 [details]
> warning dialog
> 
> This appears to be fixed when you run rhsm-icon manually as in the case above.
> 
> However, when you log in, and rhsm-icon is spawned as part of your desktop
> session loading, the pop up is on the opposite side of the icon.  See
> screenshot.
> 
> subscription-manager-gnome-0.95.5.18-1.el5.x86_64 (version found in rhel 5.7
> beta)

clarification: this doesn't ALWAYS occur on the opposite side of the task bar, it seems to shift along the whole bar.
Comment 6 James Bowes 2011-05-25 08:06:42 EDT
fixed in master, I've set the first status check to not run until a few minutes after launch. this should be enough time for the panel to load up and position the icon correctly.
commit is 5f2424b3db15b7b67170544b4a3158d8c8906126
Comment 8 J.C. Molet 2011-07-26 12:27:40 EDT
The icon now pops up many minutes after login and I cannot replicate the issue anymore.  Moving to VERIFIED.

subscription-manager-0.96.4-1.git.63.7bb4765.el6.x86_64
subscription-manager-firstboot-0.96.4-1.git.63.7bb4765.el6.x86_64
python-rhsm-0.96.7-1.git.4.ae2c338.el6.noarch
subscription-manager-gnome-0.96.4-1.git.63.7bb4765.el6.x86_64
Comment 9 errata-xmlrpc 2011-12-06 12:13:48 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.