Bug 70062 - /sbin/raid0run linked with libpopt.so
/sbin/raid0run linked with libpopt.so
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: raidtools (Show other bugs)
7.2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Arjan van de Ven
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-29 15:56 EDT by Chuck Lever
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-29 15:56:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chuck Lever 2002-07-29 15:56:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
When recovering from a RAID problem, the system comes up without /usr
mounted.  When the startup scripts attempt to run /sbin/raid0run to
recover, they fail because raid0run needs to load /usr/lib/libpopt.so.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Put system in single user mode
2.  Be sure /usr is unmounted
3.  Try to run /sbin/raid0run
	

Actual Results:  error messages from the loader that report missing library
libpopt.so when trying to execute /sbin/raid0run.  raid0run
does not start.

Expected Results:  /sbin/raid0run should start up and run without an error.

Additional info:

A workaround is available:  simply copy /usr/lib/libpopt* to /lib.
However, a file in /sbin should be completely statically linked.
The proper fix is to link libpopt when building the raid0run
executable.
Comment 1 Michael K. Johnson 2002-08-07 16:37:25 EDT
Summary was wrong; raid0run not being linked with libpopt.so would be
good; being linked with libpopt.so means that a problem shows up at
run time.

This is fixed in Red Hat Linux 7.3:
$ ldd /sbin/raid0run 
	libc.so.6 => /lib/i686/libc.so.6 (0x42000000)
	/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

Note You need to log in before you can comment on or make changes to this bug.