Bug 700689 - after S3 ,guest black screen but network remains
after S3 ,guest black screen but network remains
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.7
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Gleb Natapov
Virtualization Bugs
:
: 701594 (view as bug list)
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2011-04-28 23:03 EDT by Xiaoqing Wei
Modified: 2013-12-08 19:54 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-20 04:46:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
guest black screen (15.86 KB, image/png)
2011-04-28 23:03 EDT, Xiaoqing Wei
no flags Details
guest info (19.82 KB, image/png)
2011-04-28 23:04 EDT, Xiaoqing Wei
no flags Details

  None (edit)
Description Xiaoqing Wei 2011-04-28 23:03:24 EDT
Created attachment 495696 [details]
guest black screen

Description of problem:
cant push guest into S3 state

Version-Release number of selected component (if applicable):
kvm-83-231.el5

How reproducible:
10/10

Steps to Reproduce:
1.boot a rhel6.1-64 guest
qemu-kvm .... -balloon none

2. echo mem > /sys/power/state
3.
  
Actual results:
guest stuck at black screen,irresponsive

Expected results:
guest entering S3 state and resume

Additional info:
host info:
kernel-2.6.18-238.el5
kvm-83-231.el5
cpu:
processor       : 7
vendor_id       : GenuineIntel
cpu family      : 6
model           : 26
model name      : Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz
stepping        : 4
cpu MHz         : 1600.000
cache size      : 8192 KB
physical id     : 0

12GB ram


guest info :
rhel6.1-64


full cmd:
 qemu-kvm -name rhel61-64 -monitor stdio -serial unix:/tmp/serial-20110427-113806-qvXd,server,nowait -drive file=/usr/local/staf/test/RHEV/kvm/autotest/client/tests/kvm/images/RHEL-Server-6.1-64.qcow2,index=0,if=ide,media=disk,cache=none,format=qcow2 -net nic,vlan=0,model=rtl8139,macaddr=9a:ef:33:43:be:ab -net tap,vlan=0,ifname=t0-113806-qvXd,script=/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/scripts/qemu-ifup,downscript=no  -m 1024 -smp 4,cores=1,threads=1,sockets=4 -cpu qemu64,+sse2 -soundhw ac97 -spice port=8000,disable-ticketing -qxl 1 -rtc-td-hack -M rhel5.6.0 -boot c -usbdevice tablet -no-kvm-pit-reinjection \
-balloon none
Comment 1 Xiaoqing Wei 2011-04-28 23:04:28 EDT
Created attachment 495697 [details]
guest info

guest using kvm-clock as clock source
Comment 2 Xiaoqing Wei 2011-04-29 00:56:27 EDT
retest with vnc and drop qxl/spice from cmd,hit the same issue
Comment 3 Xiaoqing Wei 2011-05-11 04:08:55 EDT
(In reply to comment #0)
> Created attachment 495696 [details]
> guest black screen
> 

correction:
 the guest finished S3 and back,
SSH still responsive,but the screen keeps black,cant input && not output any message.



can see dmesg via ssh after S3:


[root@virtlab-66-85-138 ~]# dmesg 
PM: Syncing filesystems ... done.
Freezing user space processes ... (elapsed 0.00 seconds) done.
Freezing remaining freezable tasks ... (elapsed 0.00 seconds) done.
Suspending console(s) (use no_console_suspend to debug)
sd 0:0:0:0: [sda] Synchronizing SCSI cache
sd 0:0:0:0: [sda] Stopping disk
Intel ICH 0000:00:04.0: PCI INT A disabled
uhci_hcd 0000:00:01.2: PCI INT D disabled
ACPI: Preparing to enter system sleep state S3
Disabling non-boot CPUs ...
CPU 1 is now offline
SMP alternatives: switching to UP code
Back to C!
Enabling non-boot CPUs ...
SMP alternatives: switching to SMP code
Booting Node 0 Processor 1 APIC 0x1
mce: CPU supports 0 MCE banks
kvm-clock: cpu 1, msr 0:2035f01, secondary cpu clock
CPU1 is up
ACPI: Waking up from system sleep state S3
ata_piix 0000:00:01.1: restoring config space at offset 0x1 (was 0x2800000, writing 0x2800005)
uhci_hcd 0000:00:01.2: PCI INT D -> Link[LNKD] -> GSI 11 (level, high) -> IRQ 11
usb usb1: root hub lost power or was reset
Intel ICH 0000:00:04.0: PCI INT A -> Link[LNKD] -> GSI 11 (level, high) -> IRQ 11
ata2.01: NODEV after polling detection
ata1.01: NODEV after polling detection
ata2.00: configured for MWDMA2
ata1.00: configured for MWDMA2
usb 1-2: reset full speed USB device using uhci_hcd and address 2
sd 0:0:0:0: [sda] Starting disk
Restarting tasks ... done.
[root@virtlab-66-85-138 ~]#
Comment 4 FuXiangChun 2011-05-11 04:55:56 EDT
*** Bug 701594 has been marked as a duplicate of this bug. ***
Comment 5 Xiaoqing Wei 2011-05-11 22:13:40 EDT
(In reply to comment #3)
> (In reply to comment #0)
> > Created attachment 495696 [details]
> > guest black screen

There are 3 results after issue "echo mem > /sys/power/state" to guest.

depends on boot the guest with what kind of display protocol(VNC/SPICE) && runlevel :

1. runlevel 3(text mode) + VNC :          -> SSH available, screen freezed.

2. runlevel 5(graphic mode) + VNC :       -> SSH available, graphic available

3. runlevel 3 / 5 + SPICE :               -> SSH available, screen freezed.
Comment 7 Suqin Huang 2011-07-20 05:02:51 EDT
Hi gleb,
The bug will block s3, can you give the explain for wontfix
Comment 8 Gleb Natapov 2011-07-20 05:09:22 EDT
(In reply to comment #7)
> Hi gleb,
> The bug will block s3, can you give the explain for wontfix

And the use for s3 with Linux guest is .....? Since the rhel5 line is at the end of development cycle only customer reported critical bugs will be fixed.

Note You need to log in before you can comment on or make changes to this bug.