Bug 700695 - setup-ds-admin.pl does not like ipv6 only hostnames
Summary: setup-ds-admin.pl does not like ipv6 only hostnames
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: 389
Classification: Retired
Component: Install/Uninstall
Version: 1.2.8
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Nathan Kinder
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
Depends On:
Blocks: 690319
TreeView+ depends on / blocked
 
Reported: 2011-04-29 03:24 UTC by AJ Guillon
Modified: 2015-01-04 23:48 UTC (History)
1 user (show)

Fixed In Version: 389-ds-base-1.2.11-0.1.a1.fc17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-04 23:17:40 UTC


Attachments (Terms of Use)
setup-ds-admin.pl -ddd output (42.66 KB, text/plain)
2011-04-29 15:03 UTC, AJ Guillon
no flags Details

Description AJ Guillon 2011-04-29 03:24:25 UTC
Description of problem:

I am attempting to setup Directory 389 in a pure ipv6 environment.  I have added an ldap host (with an AAAA record only) to bind that I will just call "example.com".  During the execution of the setup script, I get to the stage:

Computer name [xxx.com]: example.com

WARNING: There are problems with the hostname.
Could not find an address for hostname 'example.com'.

It looks to me that the script is only searching for ipv4 hosts, and since I'm in a pure ipv6 environment nothing is found.  I can ping6 example.com with no issues, and dig shows everything is working just fine.

Version-Release number of selected component (if applicable):

1.2.8.2 

How reproducible:

Have run the script twice, results are the same.  Setup fails at the end when the host cannot be found.  Have only attempted on one machine, since it seems pretty clear to me what the problem is.

Steps to Reproduce:
1. Setup machine with ipv6 address only
2. Attempt setup with this machine
3. See bug.
  
Actual results:

N/A

Expected results:

N/A

Additional info:

Comment 1 AJ Guillon 2011-04-29 15:03:56 UTC
Created attachment 495793 [details]
setup-ds-admin.pl -ddd output

Here is an example where I have done the configuration with -ddd option.

Comment 2 Martin Kosek 2012-01-04 13:23:37 UTC
Upstream ticket:
https://fedorahosted.org/389/ticket/46

Comment 3 Nathan Kinder 2013-03-04 23:17:40 UTC
This was fixed in 389-ds-base-1.2.11-0.1.a1.fc17.  Closing.


Note You need to log in before you can comment on or make changes to this bug.