Bug 70071 - PHP manual pacackage is *very* excessively large
PHP manual pacackage is *very* excessively large
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
7.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Phil Copeland
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-29 18:47 EDT by Need Real Name
Modified: 2007-03-26 23:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-29 18:47:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-07-29 18:47:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (Win98; U)

Description of problem:
The PHP manual package from the RH7.0 updates thru to the current RH7.3 release is *very* large.  (rpm -qip claims ~110M for 7.0updates and 
7.3;  actual used space on 7.0 runs ~150M+;  I did not have a system with enough space in /var to install the 7.3 package for comparison.)  The 
Rawhide package is even bigger, claiming ~190M.

Version-Release number of selected component (if applicable):
4.0.6-13 for RH7.0;  4.1.2-7 for RH7.3;  newest Rawhide package on www.rpmfind.net is 4.2.2-2

How reproducible:
Always

Steps to Reproduce:
Install RHL v7.0 or newer.  Install all errata.

Additional info:

If possible, I'd like to see the various languages split off into subpackages rather than bundled as one monolithic block which may not even install 
on small servers due to disk space limits.  English is in the main directory (/var/www/html/manual/mod/mod_php4 by default);  other languages are 
in subdirectories of that directory.  From what little rpm-building I've done, this should be a *trivial* change.
Comment 1 Phil Copeland 2002-07-29 19:08:27 EDT
It is what it is
the package is languified and will only install the manuals for the languages
you selected to use during the initial loading of the base OS

Phil
=--=

Note You need to log in before you can comment on or make changes to this bug.