Bug 700758 - Broken dependency on deprecated hal
Broken dependency on deprecated hal
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: oxine (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-29 06:31 EDT by Nicola Soranzo
Modified: 2011-05-09 05:33 EDT (History)
1 user (show)

See Also:
Fixed In Version: oxine-0.7.1-11.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-09 05:33:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicola Soranzo 2011-04-29 06:31:28 EDT
Description of problem:
Since HAL has been deprecated upstream for 3 years, all major distributions are removing it. You can find more details on the proposed Fedora Feature page:

https://fedoraproject.org/wiki/Features/HalRemoval

The hal package has already been deprecated by its maintainer and blocked from composes for rawhide.
Therefore, unless somebody volunteers to maintain hal, the following broken dependencies for your package should be removed:

oxine-0.7.1-10.fc15.i686 requires libhal.so.1
oxine-0.7.1-10.fc15.i686 requires libhal-storage.so.1

Version-Release number of selected component (if applicable):

oxine-0.7.1-10.fc15

Note You need to log in before you can comment on or make changes to this bug.