Bug 700831 - "Networking system disabled" message when connected to the network
"Networking system disabled" message when connected to the network
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kde-plasma-networkmanagement (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16Target-kde
  Show dependency treegraph
 
Reported: 2011-04-29 10:33 EDT by Jaroslav Reznik
Modified: 2011-04-30 23:24 EDT (History)
3 users (show)

See Also:
Fixed In Version: kdebase-workspace-4.6.2-6.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-30 23:24:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XML introspection patch (1.90 KB, patch)
2011-04-29 13:04 EDT, Jaroslav Reznik
no flags Details | Diff

  None (edit)
Description Jaroslav Reznik 2011-04-29 10:33:49 EDT
Description of problem: "Network disabled" message when connected to the network, should be "Network enabled"

Version-Release number of selected component (if applicable):
0.9-0.46.20110420-1.fc15

How reproducible:
Everytime

Steps to Reproduce:
1. connect to network
2. check error message

  
Actual results:
"Network disabled" message

Expected results:
 "Network enabled" message

Additional info:
Comment 1 Jaroslav Reznik 2011-04-29 12:26:46 EDT
The problem is - knm uses partially NM 0.8 compat interfaces but the main NetworkManager object is from 0.9 and it NM 0.9 changes NM_STATEs to more granular system (compare http://projects.gnome.org/NetworkManager//developers/spec-08.html#type-NM_STATE and http://projects.gnome.org/NetworkManager/developers/migrating-to-09/spec.html#type-NM_STATE) not documented in migration guide (only new device states are documented).
Comment 2 Jaroslav Reznik 2011-04-29 13:04:18 EDT
Created attachment 495816 [details]
XML introspection patch
Comment 3 Jaroslav Reznik 2011-04-29 13:52:54 EDT
Ops, sorry, it really uses Compat interface... But still somehow related to improper state processing.
Comment 4 Jaroslav Reznik 2011-04-29 17:48:48 EDT
The problem is clear now - it does not use generated definitions from XML introspection file but unfortunatelly from NetworkManager.h (from NetworkManager-devel package) that's already in version 0.9. It should not work but there's a #define for compat reasons that assignes NM_STATE_CONNECTED value of NM_STATE_CONNECTED_GLOBAL. 

I'll post the patch tomorrow.
Comment 5 Fedora Update System 2011-04-30 05:19:58 EDT
kdebase-workspace-4.6.2-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kdebase-workspace-4.6.2-5.fc15
Comment 6 Fedora Update System 2011-04-30 23:24:15 EDT
kdebase-workspace-4.6.2-6.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.