Bug 700922 - don't download kernel-debug-debuginfo.rpm unless it's really necessary
Summary: don't download kernel-debug-debuginfo.rpm unless it's really necessary
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: abrt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ABRTF17
TreeView+ depends on / blocked
 
Reported: 2011-04-29 19:43 UTC by John Reiser
Modified: 2012-04-18 22:58 UTC (History)
7 users (show)

Fixed In Version: abrt-2.0.10-1.fc17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-18 22:58:27 UTC
Type: ---


Attachments (Terms of Use)

Description John Reiser 2011-04-29 19:43:07 UTC
Description of problem: When an application kills itself, such as with SIGABRT from assert(), then abrt processes the debug info kernel-debug-debuginfo-...-.rpm.  This is because the source code to kill() is inside linux-vdso.so.1:
-----
Program terminated with signal 6, Aborted.
#0  __kernel_vsyscall () at arch/x86/vdso/vdso32/int80.S:16
16	arch/x86/vdso/vdso32/int80.S: No such file or directory.
	in arch/x86/vdso/vdso32/int80.S
-----
That .rpm is very large; it can require several minutes to download/uncompress/extract, and also needs many tens of megabytes of disk space.  The combined effect of long delay, high network load, long CPU time, and big disk usage is unreasonable because it is so large, yet gives almost no information.

Version-Release number of selected component (if applicable):
abrt-2.0.1-2.fc15.x86_64.rpm

How reproducible: every time


Steps to Reproduce:
1. assert(0);
2.
3.
  
Actual results: abrt processing takes a long time, much of it at heavy load:
-----
2011-04-29-10:22:22  Downloading (35 of 41) kernel-PAEdebug-debuginfo-2.6.38.3-18.fc15.i686.rpm:  10%
2011-04-29-10:22:32  Downloading (35 of 41) kernel-PAEdebug-debuginfo-2.6.38.3-18.fc15.i686.rpm:  17%
2011-04-29-10:22:43  Downloading (35 of 41) kernel-PAEdebug-debuginfo-2.6.38.3-18.fc15.i686.rpm:  24%
2011-04-29-10:22:53  Downloading (35 of 41) kernel-PAEdebug-debuginfo-2.6.38.3-18.fc15.i686.rpm:  30%
2011-04-29-10:23:04  Downloading (35 of 41) kernel-PAEdebug-debuginfo-2.6.38.3-18.fc15.i686.rpm:  38%
2011-04-29-10:23:15  Downloading (35 of 41) kernel-PAEdebug-debuginfo-2.6.38.3-18.fc15.i686.rpm:  42%
2011-04-29-10:23:26  Downloading (35 of 41) kernel-PAEdebug-debuginfo-2.6.38.3-18.fc15.i686.rpm:  49%
2011-04-29-10:23:37  Downloading (35 of 41) kernel-PAEdebug-debuginfo-2.6.38.3-18.fc15.i686.rpm:  58%
2011-04-29-10:23:48  Downloading (35 of 41) kernel-PAEdebug-debuginfo-2.6.38.3-18.fc15.i686.rpm:  65%
2011-04-29-10:23:58  Downloading (35 of 41) kernel-PAEdebug-debuginfo-2.6.38.3-18.fc15.i686.rpm:  72%
2011-04-29-10:24:10  Downloading (35 of 41) kernel-PAEdebug-debuginfo-2.6.38.3-18.fc15.i686.rpm:  80%
2011-04-29-10:24:20  Downloading (35 of 41) kernel-PAEdebug-debuginfo-2.6.38.3-18.fc15.i686.rpm:  86%
2011-04-29-10:24:31  Downloading (35 of 41) kernel-PAEdebug-debuginfo-2.6.38.3-18.fc15.i686.rpm:  95%
2011-04-29-10:24:48  Downloading (35 of 41) kernel-PAEdebug-debuginfo-2.6.38.3-18.fc15.i686.rpm: 100%
2011-04-29-10:24:48  Extracting cpio from /tmp/abrt-tmp-debuginfo-2011-04-29-10:16:21.1529/kernel-PAEdebug-debuginfo-2.6.38.3-18.fc15.i686.rpm
2011-04-29-10:28:07  Caching files from unpacked.cpio made from kernel-PAEdebug-debuginfo-2.6.38.3-18.fc15.i686.rpm
2011-04-29-10:29:24  Downloading (36 of 41) libICE-debuginfo-1.0.6-3.fc15.i686.rpm: 100%
-----
which took 7 minutes elapsed (from 10:22:22 to 10:29:24) including 4.6 minutes of high CPU+IO (from 10:24:48 to 10:29:24).

Expected results: Ignore kernel-debug-debuginfo.rpm for any application crash, or at least for SIGABRT.


Additional info:  The only information for all that work is these two lines:
-----
Dump of assembler code for function __kernel_vsyscall:
   0x00cfe414 <+0>:	int    $0x80
=> 0x00cfe416 <+2>:	ret    
-----
which is trivial.  This knowledge somehow should be built-in to abrt.

Comment 1 Jiri Moskovcak 2011-05-06 14:20:13 UTC
Agreed the kernel-debuginfo is not needed in many cases. I will improve the logic in our debuginfo-install code to don't install this package until it's really necessary (like a crash in some binary which comes from some kernel subpackage)

Comment 2 Jiri Moskovcak 2011-10-10 13:27:49 UTC
Current version should not install the kernel-debuginfo.

Comment 3 John Reiser 2011-11-08 05:04:43 UTC
This bug persists in Fedora 17 rawhide; see bug 751936 for example.  Also, the kernel-debug-*.rpm is now larger than 110MB, and it takes almost twenty minutes to download, run rpm2cpio, run cpio, and cache the files (4 passes!)  PLEASE put in a special case: do NOT download or process kernel-debug-*.rpm for a user-mode abort.

abrt-2.0.6-1.fc17.i686
abrt-addon-ccpp-2.0.6-1.fc17.i686
abrt-addon-kerneloops-2.0.6-1.fc17.i686
abrt-addon-python-2.0.6-1.fc17.i686
abrt-addon-vmcore-2.0.6-1.fc17.i686
abrt-desktop-2.0.6-1.fc17.i686
abrt-gui-2.0.6-1.fc17.i686
abrt-libs-2.0.6-1.fc17.i686
abrt-retrace-client-2.0.6-1.fc17.i686

Comment 4 Jiri Moskovcak 2011-11-08 07:29:36 UTC
abrt skips "linux-vdso.so.1" which usually brings the kernel-debuginfo, but you probably found another case, can you please send me build_ids from the directory where your crash lives? Should be $HOME/.abrt/spool/ccpp-<SOMETHING>

Comment 5 John Reiser 2011-11-08 15:13:01 UTC
The build_ids are in
   https://bugzilla.redhat.com/attachment.cgi?id=532187
which is part of bug 751936.  The dso_list is also attached to that bug, as is other info.

Comment 6 Jiri Moskovcak 2011-12-15 12:27:37 UTC
I can't reproduce it, as I said in the comment#2 we already ignore linux-vdso.so.1, it must have been something else in your case what pulled in the kernel debuginfo. This is what I get on Fedora16 for core created by:

#include <assert.h>

int main(void)
{
  assert(0);
  return 0;
}
 

[10:20:51 jmoskovc@dhcp-24-187 ~]$ eu-unstrip --core=core.3621 -n
0x400000+0x201000 ddfd6a771444016f9d4cd270d54f72d937e23fad@0x40024c - - [exe]
0x7fff1e3e2000+0x1000 9f6a5fda6fec28b048eb78a4340676aa14bf9be5@0x7fff1e3e2340 . - linux-vdso.so.1
0x7f1c31c4b000+0x3b6000 e02146cbd7b3747790cf4808baa58dc78c2e0042@0x7f1c31c4b280 /lib64/libc.so.6 - libc.so.6
0x7f1c32001000+0x224000 3ed9e61c2b7e707ce244816335776afa2ad0307d@0x7f1c320011d8 /lib64/ld-linux-x86-64.so.2 - ld-linux-x86-64.so.2

[10:24:32 jmoskovc@dhcp-24-187 ~]$ abrt-action-analyze-core -c core.3621 -o build_ids
Analyzing coredump 'core.3621'
ddfd6a771444016f9d4cd270d54f72d937e23fad
3ed9e61c2b7e707ce244816335776afa2ad0307d
e02146cbd7b3747790cf4808baa58dc78c2e0042

- as you can see ABRT skipped 9f6a5fda6fec28b048eb78a4340676aa14bf9be5 which is the build_id of linux-vdso.so.1 and the rest of thep process just tries to download glibc-debuginfo which is correct.
- if I manage to install F17 I will try to reproduce it there, but I'm still convinced that it's something else than vdso pulling the kernel-debug and we can't hardcode everything..

Comment 7 Jiri Moskovcak 2011-12-15 13:32:17 UTC
After some testing we found that linux-gate.so.1 is to blame for pulling the kernel debuginfo. I'm going to add this to our ignore list in debuginfo install logic.

Comment 8 Jiri Moskovcak 2011-12-15 13:56:29 UTC
Fixed in git (commit: 98337aa31e8b72c664efe5ef2674e27cd97dcbd5)

Comment 9 Fedora Admin XMLRPC Client 2011-12-19 17:43:34 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 10 Fedora Admin XMLRPC Client 2011-12-19 17:46:14 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 11 John Reiser 2012-01-07 17:52:31 UTC
This problem persists in rawhide for Fedora 17:
   abrt-2.0.7-3.fc17.i686 which is greater than the claimed fix of
   abrt-2.0.4.981-1.fc16

See https://bugzilla.redhat.com/show_bug.cgi?id=769409#c6
I endured a 250MB download of kernel-debuginfo and 1.2GB expansion (approx. 9 minutes).  The relevant traceback portion seems to be:
-----
   Thread 3 (Thread 0xb6effb40 (LWP 1144)):
   #0  __kernel_vsyscall () at arch/x86/vdso/vdso32/int80.S:16
   No locals.
   #1  0x001f4f00 in __GI___poll (fds=fds@entry=0xb6502298, nfds=nfds@entry=3, timeout=timeout@entry=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
-----
which again gives no added information despite all the work.

Comment 12 Jiri Moskovcak 2012-01-09 09:16:36 UTC
It's not really fixed, the "fixed in" field was filled by mistake. The fix is only in git and needs to be pushed.

Comment 13 Jiri Moskovcak 2012-01-09 11:51:19 UTC
...needs to be pushed to Fedora.

Comment 14 John Reiser 2012-02-27 16:48:49 UTC
Ping?  abrt-2.0.7-4.fc17.i686 still downloads  kernel-*-debuginfo when not needed.  My machine is unusable for half an hour.  I watched using '/usr/bin/top' and saw:
   5 minutes download kernel-PAE-debuginfo
  10 minutes rpm2cpio      (4   minutes CPU time for rpm2cpio process)
  11 minutes caching cpio  (3.8 minutes CPU time for cpio     process)
The "pendulum" which moves back and forth across the window (to signify "abrt is working") causes Xorg to consume about 40% CPU (1.6GHz Pentium4, Radeon 9250 rv280 graphics.)

From the $HOME/.abrt/spool/<instance>/event_log:
-----
2012-02-23-14:52:34> Analyzing coredump 'coredump'
2012-02-23-14:52:37  Coredump references 13 debuginfo files, 13 of them are not installed
2012-02-23-14:52:38  Setting up yum repositories
2012-02-23-14:52:48  Looking for needed packages in repositories
2012-02-23-14:53:29  Packages to download: 6
2012-02-23-14:53:34  Downloading 292.99Mb, installed size: 1325.38Mb. Continue? YES
2012-02-23-14:53:39  Downloading (1 of 6) glib2-debuginfo-2.31.16-2.fc17.i686.rpm: 100
2012-02-23-14:53:39  Extracting cpio from /tmp/abrt-tmp-debuginfo-2012-02-23-14:52:37.3695/glib2-debuginfo-2.31.16-2.fc17.i686.rpm
2012-02-23-14:53:48  Caching files from unpacked.cpio made from glib2-debuginfo-2.31.16-2.fc17.i686.rpm
2012-02-23-14:54:00  Downloading (2 of 6) libffi-debuginfo-3.0.10-2.fc17.i686.rpm: 100
2012-02-23-14:54:00  Extracting cpio from /tmp/abrt-tmp-debuginfo-2012-02-23-14:52:37.3695/libffi-debuginfo-3.0.10-2.fc17.i686.rpm
2012-02-23-14:54:00  Caching files from unpacked.cpio made from libffi-debuginfo-3.0.10-2.fc17.i686.rpm
2012-02-23-14:54:03  Downloading (3 of 6) gnome-settings-daemon-debuginfo-3.3.5-2.fc17.i686.rpm: 100
2012-02-23-14:54:03  Extracting cpio from /tmp/abrt-tmp-debuginfo-2012-02-23-14:52:37.3695/gnome-settings-daemon-debuginfo-3.3.5-2.fc17.i686.rpm
2012-02-23-14:54:05  Caching files from unpacked.cpio made from gnome-settings-daemon-debuginfo-3.3.5-2.fc17.i686.rpm
2012-02-23-14:54:14  Downloading (4 of 6) glibc-debuginfo-2.15-23.fc17.i686.rpm:  43
2012-02-23-14:54:18  Downloading (4 of 6) glibc-debuginfo-2.15-23.fc17.i686.rpm: 100
2012-02-23-14:54:18  Extracting cpio from /tmp/abrt-tmp-debuginfo-2012-02-23-14:52:37.3695/glibc-debuginfo-2.15-23.fc17.i686.rpm
2012-02-23-14:54:45  Caching files from unpacked.cpio made from glibc-debuginfo-2.15-23.fc17.i686.rpm
2012-02-23-14:55:28  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:   2
2012-02-23-14:55:35  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:   4
2012-02-23-14:55:41  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:   6
2012-02-23-14:55:48  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:   8
2012-02-23-14:55:55  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  10
2012-02-23-14:56:01  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  12
2012-02-23-14:56:08  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  14
2012-02-23-14:56:16  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  16
2012-02-23-14:56:23  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  18
2012-02-23-14:56:32  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  20
2012-02-23-14:56:38  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  22
2012-02-23-14:56:44  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  24
2012-02-23-14:56:50  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  26
2012-02-23-14:56:57  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  28
2012-02-23-14:57:02  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  30
2012-02-23-14:57:10  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  32
2012-02-23-14:57:17  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  34
2012-02-23-14:57:22  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  36
2012-02-23-14:57:28  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  38
2012-02-23-14:57:33  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  40
2012-02-23-14:57:41  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  42
2012-02-23-14:57:48  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  44
2012-02-23-14:57:56  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  46
2012-02-23-14:58:02  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  48
2012-02-23-14:58:07  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  50
2012-02-23-14:58:14  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  52
2012-02-23-14:58:22  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  54
2012-02-23-14:58:28  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  56
2012-02-23-14:58:34  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  58
2012-02-23-14:58:41  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  60
2012-02-23-14:58:52  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  62
2012-02-23-14:58:55  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  64
2012-02-23-14:59:02  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  66
2012-02-23-14:59:08  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  68
2012-02-23-14:59:15  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  70
2012-02-23-14:59:22  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  72
2012-02-23-14:59:27  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  74
2012-02-23-14:59:34  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  76
2012-02-23-14:59:40  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  78
2012-02-23-14:59:49  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  80
2012-02-23-14:59:55  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  82
2012-02-23-15:00:02  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  84
2012-02-23-15:00:09  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  86
2012-02-23-15:00:15  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  88
2012-02-23-15:00:23  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  90
2012-02-23-15:00:27  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  92
2012-02-23-15:00:35  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  94
2012-02-23-15:00:42  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  96
2012-02-23-15:00:49  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm:  98
2012-02-23-15:01:12  Downloading (5 of 6) kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm: 100
2012-02-23-15:01:12  Extracting cpio from /tmp/abrt-tmp-debuginfo-2012-02-23-14:52:37.3695/kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm
2012-02-23-15:11:40  Caching files from unpacked.cpio made from kernel-PAE-debuginfo-3.3.0-0.rc3.git7.2.fc17.i686.rpm
2012-02-23-15:22:04  Downloading (6 of 6) udev-debuginfo-181-2.fc17.i686.rpm: 100
2012-02-23-15:22:04  Extracting cpio from /tmp/abrt-tmp-debuginfo-2012-02-23-14:52:37.3695/udev-debuginfo-181-2.fc17.i686.rpm
2012-02-23-15:22:08  Caching files from unpacked.cpio made from udev-debuginfo-181-2.fc17.i686.rpm
2012-02-23-15:22:10  Removing /tmp/abrt-tmp-debuginfo-2012-02-23-14:52:37.3695
2012-02-23-15:22:10  All 13 debuginfo files are available
2012-02-23-15:22:11  Generating backtrace
2012-02-23-15:22:15  Backtrace is generated and saved, 16726 bytes
2012-02-23-15:22:19  Searching for updates
2012-02-23-15:23:25> Logging into Bugzilla at https://bugzilla.redhat.com
2012-02-23-15:23:27  Checking for duplicates
2012-02-23-15:23:30  Bug is already reported: 789296
2012-02-23-15:23:30  Add jreiser@BitWagon.com to CC list
2012-02-23-15:23:31  Adding new comment to bug 789296
2012-02-23-15:23:34  Attaching better backtrace
2012-02-23-15:23:35  Logging out
2012-02-23-15:23:36  Status: NEW https://bugzilla.redhat.com/show_bug.cgi?id=789296
-----

Comment 15 Fedora Update System 2012-03-27 10:16:35 UTC
abrt-2.0.9-1.fc17, libreport-2.0.10-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/abrt-2.0.9-1.fc17,libreport-2.0.10-1.fc17

Comment 16 Fedora Update System 2012-03-28 05:57:22 UTC
Package abrt-2.0.9-1.fc17, libreport-2.0.10-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.9-1.fc17 libreport-2.0.10-1.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4804/abrt-2.0.9-1.fc17,libreport-2.0.10-1.fc17
then log in and leave karma (feedback).

Comment 17 Fedora Update System 2012-04-02 13:32:22 UTC
abrt-2.0.10-1.fc17,libreport-2.0.10-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/abrt-2.0.10-1.fc17,libreport-2.0.10-2.fc17

Comment 18 Fedora Update System 2012-04-18 22:58:27 UTC
abrt-2.0.10-1.fc17, libreport-2.0.10-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.