Bug 70097 - Save systematically intermediary files under /tmp during a download. What to do when /tmp is small???...
Save systematically intermediary files under /tmp during a download. What to ...
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: mozilla (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-30 07:05 EDT by Need Real Name
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-30 07:05:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-07-30 07:05:29 EDT
Description of Problem:
When I download a file, Mozilla SYSTEMATICALLY creates an intermediary copy
under /tmp. My /tmp partition is of limited size, therefore I am limited in the
size of the files I download even if the destination directory is MUCH larger
than /tmp


Version-Release number of selected component (if applicable):
1.0.1-9

How Reproducible:


Steps to Reproduce:
1. Have a machine with a /tmp partition of a limited size (Let's say 128Mb) and
a /home partition of about 1Gb
2. go to, for instance, http://www.enlightenment.org/pages/source.html and try
to download http://cvs.sourceforge.net/cvstarballs/enlightenment-cvsroot.tar.gz
(235Mb) under your home directory (/home/my_directory, as I said about 1Gb large) 
3. Wait until the download crashes because /tmp is full... (even if /tmp is NOT
supposed to be involved in the download...)


Actual Results:
Download stopped.


Expected Results:
File downloaded under /home/my_directory without any "left-over" under /tmp
Comment 1 Christopher Blizzard 2002-08-30 10:26:51 EDT
Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.