Bug 700973 - Regression of Wireless performance on Atheros AR928X adapter
Regression of Wireless performance on Atheros AR928X adapter
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-29 23:15 EDT by Brandon Sharitt
Modified: 2012-06-04 15:07 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-04 15:07:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
lsmod output (2.61 KB, text/plain)
2011-04-29 23:16 EDT, Brandon Sharitt
no flags Details
lspci output (1.51 KB, text/plain)
2011-04-29 23:17 EDT, Brandon Sharitt
no flags Details
nm-tool output (1.46 KB, text/plain)
2011-04-29 23:17 EDT, Brandon Sharitt
no flags Details

  None (edit)
Description Brandon Sharitt 2011-04-29 23:15:29 EDT
Description of problem: Compared to Fedora 14, the wireless takes several seconds more to connect on boot and wake from sleep(going from less than 5 in F14 to 20-30 seconds in F15).

Once the wireless connection is actually made, the network performance is greatly degraded(a 20MB download took 5 minutes compared to the previous 5 seconds on F14). The slowdown can be counteracted by adding "hwcrypt=1" to the ath9k options.

Version-Release number of selected component (if applicable): 2.6.38.4-20.fc15.x86_64


How reproducible: Every time wifi networking is needed on a computer with a AR928X wireless NIC.


Steps to Reproduce:
1. Install Fedora 15 Beta on computer with AR928X wireless adapter
2. connect to wireless network
3. try to do anything with the network.
  
Actual results: Wireless connection takes in excess of 20 seconds to connect. Once you actually try to do anything, the network connectivity is excessively slow to the point of uselessness


Expected results: Wireless connection should be made in roughly 5 seconds and speed should be comparable to Fedora 14 and Windows.


Additional info:
Comment 1 Brandon Sharitt 2011-04-29 23:16:34 EDT
Created attachment 495903 [details]
lsmod output
Comment 2 Brandon Sharitt 2011-04-29 23:17:36 EDT
Created attachment 495904 [details]
lspci output
Comment 3 Brandon Sharitt 2011-04-29 23:17:57 EDT
Created attachment 495905 [details]
nm-tool output
Comment 4 Kevin Fenzi 2011-05-14 18:11:20 EDT
Might be a dupe/same as the issue in 702722
Comment 5 Stanislaw Gruszka 2011-07-13 08:56:51 EDT
You can check current upstream drivers to see if problem is fixed there
http://people.redhat.com/sgruszka/compact_wireless.html
Comment 6 Robert O'Callahan 2011-08-11 05:03:28 EDT
I'm having a similar problem with this adapter. I get frequent packet loss, and frequent absurdly-high ping times (probably also packet loss with automatic retransmit, I guess). The same machine sees no packet loss when running Windows and seemed to be working fine before I upgraded from F13 to F15. Other devices on the same network work fine. The AP is about three metres from the F15 box, in the same room.

I have updated to 2.6.40-4, I've tried Stanislaw's latest compat-wireless and compat-wireless-next packages with their respective kernels, and I even downloaded the compat-wireless source (August 8) from here:
http://wireless.kernel.org/download/compat-wireless-2.6/
and built it. I also tried nohwcrypt=1. Nothing makes any difference.

Any suggestions on what to try next?
Comment 7 Stanislaw Gruszka 2011-08-11 05:33:36 EDT
If bug is on current upstream driver send bug report to ath9k-devel@lists.ath9k.org and cc linux-wireless@vger.kernel.org. Note in email this is regression. You probably will be asked about providing more info, i.e dmesg with debug= module option.
Comment 8 John W. Linville 2011-08-24 11:30:14 EDT
Brandon, do these performance problems continue with 2.6.40 kernels?

Note You need to log in before you can comment on or make changes to this bug.