Bug 700983 - ccache dir owned by root
Summary: ccache dir owned by root
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mock
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Clark Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-30 09:32 UTC by Remi Collet
Modified: 2011-06-02 19:19 UTC (History)
2 users (show)

Fixed In Version: mock-1.1.10-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-19 04:38:06 UTC


Attachments (Terms of Use)
Create ccache dir ad the builder. (597 bytes, patch)
2011-04-30 09:33 UTC, Remi Collet
no flags Details | Diff
Create ccache dir as the builder. (609 bytes, patch)
2011-04-30 09:44 UTC, Remi Collet
no flags Details | Diff
Fix a regression introduced by previous patch (2.15 KB, patch)
2011-05-11 08:44 UTC, Mathieu Bridon
no flags Details | Diff

Description Remi Collet 2011-04-30 09:32:22 UTC
When ccache dir is redirected in config
config_opts['plugin_conf']['ccache_opts']['dir'] = "/dev/shm/ccache.fc15i/"


This folder is created, owned by root, so unusable.

Should be created by the builder user.

Comment 1 Remi Collet 2011-04-30 09:33:36 UTC
Created attachment 495922 [details]
Create ccache dir ad the builder.

This trivial patch seems to fix this issue.

Comment 2 Remi Collet 2011-04-30 09:44:45 UTC
Created attachment 495924 [details]
Create ccache dir as the builder.

Comment 3 Clark Williams 2011-05-06 18:53:34 UTC
queued for next release (1.1.10 and 1.0.17)

Comment 4 Mathieu Bridon 2011-05-11 08:44:17 UTC
Created attachment 498223 [details]
Fix a regression introduced by previous patch

This patch introduced a regression: in some situations (e.g default configuration), the unpriviledge user doesn't have the permissions to create the ccache dir if it doesn't exist.

Comment 5 Clark Williams 2011-05-11 13:06:17 UTC
Thanks, I was just looking at this since things worked fine on my F14 system but failed on both EL5 and EL6. I'll apply and do some more testing.

Comment 6 Fedora Update System 2011-05-13 20:31:45 UTC
mock-1.1.10-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/mock-1.1.10-1.fc15

Comment 7 Fedora Update System 2011-05-13 20:36:53 UTC
mock-1.1.10-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/mock-1.1.10-1.fc14

Comment 8 Fedora Update System 2011-05-13 20:41:06 UTC
mock-1.0.17-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/mock-1.0.17-1.el5

Comment 9 Fedora Update System 2011-05-13 20:45:17 UTC
mock-1.1.10-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/mock-1.1.10-1.fc13

Comment 10 Fedora Update System 2011-05-13 20:49:32 UTC
mock-1.1.10-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mock-1.1.10-1.el6

Comment 11 Fedora Update System 2011-05-14 00:01:44 UTC
Package mock-1.1.10-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing mock-1.1.10-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/mock-1.1.10-1.el6
then log in and leave karma (feedback).

Comment 12 Fedora Update System 2011-05-19 04:33:14 UTC
mock-1.1.10-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2011-05-25 02:40:33 UTC
mock-1.1.10-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2011-05-25 03:15:04 UTC
mock-1.1.10-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2011-06-02 19:04:44 UTC
mock-1.0.17-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2011-06-02 19:14:47 UTC
mock-1.1.10-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.