Bug 700994 - "Dim screen to save power" has no effect
"Dim screen to save power" has no effect
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
15
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-30 06:18 EDT by Philipp Dörfler
Modified: 2012-03-05 12:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-15 08:36:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Philipp Dörfler 2011-04-30 06:18:02 EDT
Description of problem:
Setting "Dim screen to save power" in gnome-power-manager has no effect

Version-Release number of selected component (if applicable):
gnome-power-manager-3.0.0-1.fc15.x86_64

How reproducible:
Always reproducible.

Steps to Reproduce:
- Open gnome's system settings in gnome3
- click on "screen"
- check "Dim screen to save power"
- unplug the power cord so the laptop runs on battery
  
Actual results:
The screen's brightness remains unchanged.

Expected results:
The screen should dim to save power.

Additional info:
Opening dconf-editor and manually toggling org.gnome.power-manager.backlight-battery-reduce works as expected. It seems that gnome-power-manager should toggle this setting in dconf, but doesn't.
Comment 1 Richard Hughes 2011-11-15 08:36:42 EST
This should be fixed in F16, please reopen if that's not the case. Thanks.
Comment 2 Gordon Messmer 2012-03-05 12:10:42 EST
Since this is one of the top google hits for "gnome dim screen to save power", I wanted to update this entry.

The "Dim screen to save power" option currently sets the dconf value /org/gnome/settings-daemon/plugins/power/idle-dim-battery.  As far as I can tell, there is no setting anywhere in GNOME 3 (in Fedora 16) that will dim the screen when a PC switches from external to battery power.

Note You need to log in before you can comment on or make changes to this bug.