Bug 70100 - incorrectly uses reverse dns lookup
Summary: incorrectly uses reverse dns lookup
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gftp (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: MoveUpstream, Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-30 11:59 UTC by Gene Czarcinski
Modified: 2007-04-18 16:44 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-20 02:14:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gene Czarcinski 2002-07-30 11:59:24 UTC
Description of Problem:
Even when a numeric ip address is used in a bookmark or manually entered, gftp
does a reverse dns lookup on the ip address and if it is not defined, it winds
up with a "bad name" -- currently "unused."  If the link stalls/times out for
some reason, gftp will try to restart the link using the name "unused." and will
fail.

This is a pain since even redhat does not always keep reverse lookup up-to-date.

Version-Release number of selected component (if applicable):
7.3.93/gftp-2.0.13-2

How Reproducible:
yes

Steps to Reproduce:
1. run gftp and select some server with no dns reverse lookup defined (such as
ftp.beta.redhat.com curently).
2. note that after the connection is established that the "name" will be
"unused." even if it was manually entered.
3. 

Actual Results:
"unused."

Expected Results:
"leave as ip address if so entered ... do not do reverse lookup (or at lease
make it an option)

Additional Information:

Comment 1 Gene Czarcinski 2002-07-30 14:37:17 UTC
I sent an email bug report on this to the upstream maintainer masneyb@gftp.org

Comment 2 Havoc Pennington 2002-12-20 02:14:42 UTC
If this has been reported upstream, closing here. We'll pull 
a new gftp version when available.


Note You need to log in before you can comment on or make changes to this bug.