This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 701036 - XMMS does not go to the next item in the playlist when using ALSA output plugin
XMMS does not go to the next item in the playlist when using ALSA output plugin
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xmms (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-30 10:04 EDT by Jaroslav Franek
Modified: 2011-07-25 23:47 EDT (History)
3 users (show)

See Also:
Fixed In Version: xmms-1.2.11-15.20071117cvs.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-25 23:30:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Franek 2011-04-30 10:04:44 EDT
Description of problem:
XMMS does not go to the next item in the playlist when using ALSA output plugin. This makes it useless for playing playlists.

Version-Release number of selected component (if applicable):
xmms-1.2.11-12.20071117cvs.fc15.x86_64

How reproducible:
Always when using ALSA output plugin

Steps to Reproduce:
1. open a playlist
2. click on a song to play
3.
  
Actual results:
After playing a song, the XMMS does not go to the next in the playlist, nor it "stops": the progress button remains indefinitely at the rightmost position for the song that was played.
XMMS does not crash or hang. It just plays one song at that is it.


Expected results:
Enable to play songs on the playlist in sequence, using ALSA output plugin.

Additional info:
Works OK with PulseAudio output plugin, but on old hardware PulseAudio has significant CPU footprint, while ALSA does not, hence I prefer ALSA output on my old system.
Comment 1 Neil 2011-06-04 19:05:14 EDT
I'm seeing the same thing on a HP Pavilion DV8120CA laptop.  Same version of xmms; playback hangs at the end of each song, but will continue if the [>|] button is pressed.  Works with the Pulse plugin; it's only ALSA that fails.
Comment 2 Stuart R. DeGraaf 2011-07-10 10:20:32 EDT
I see exactly the same behaviour as Neil and Jaroslav
Fedora 15 2.6.38.8-32.fc15.x86_64
xmms-1.2.11-12.20071117cvs.fc15.x86_64
Comment 3 Fedora Admin XMLRPC Client 2011-07-14 14:44:58 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Tom "spot" Callaway 2011-07-14 17:27:07 EDT
There are all sorts of spiders and horrible things in this code, but I'm looking at it.
Comment 5 Tom "spot" Callaway 2011-07-15 16:18:42 EDT
Okay, I have a fix, but the ALSA plugin code, like much of ALSA itself, is still incredibly touchy. I strongly encourage you to consider the xmms-pulse output plugin instead.
Comment 6 Fedora Update System 2011-07-15 16:41:37 EDT
xmms-1.2.11-15.20071117cvs.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/xmms-1.2.11-15.20071117cvs.fc14
Comment 7 Fedora Update System 2011-07-15 16:41:57 EDT
xmms-1.2.11-15.20071117cvs.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/xmms-1.2.11-15.20071117cvs.fc15
Comment 8 Michael Schwendt 2011-07-15 16:51:16 EDT
> I strongly encourage you to consider the xmms-pulse output plugin instead.

If only it were not unmaintained:
https://bugzilla.redhat.com/buglist.cgi?component=xmms-pulse&product=Fedora

The ALSA plugin developers of Audacious are very active, btw:
http://mschwendt.fedorapeople.org/XMMS-vs-Audacious_Screenshot.png
Comment 9 Fedora Update System 2011-07-16 03:34:41 EDT
Package xmms-1.2.11-15.20071117cvs.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xmms-1.2.11-15.20071117cvs.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/xmms-1.2.11-15.20071117cvs.fc15
then log in and leave karma (feedback).
Comment 10 Neil 2011-07-16 18:44:28 EDT
New version still has the same problem!  Do I need to restart ALSA (how?), or reboot?

% rpm -q xmms
xmms-1.2.11-15.20071117cvs.fc15.x86_64
% uname -r
2.6.38.8-32.fc15.x86_64
% cat /etc/fedora-release 
Fedora release 15 (Lovelock)
Comment 11 Jaroslav Franek 2011-07-17 08:13:09 EDT
The fix works for me.

@Neil: Have you tried to update xmms-libs package as well?

The comment #9 tells you to update xmms package. I tried, but noticed there is xmml-libs package of the same version-release. For some reason, however, the xmms-libs was not picked up by yum when I tried yum update xmms. So I did

# yum --enablerepo=updates-testing update xmms*

Seems to me that xmms package is missing rpm requires for specific version-release of xmms-libs though these two packages are built from the same src.rpm.
Comment 12 Neil 2011-07-17 08:38:45 EDT
> @Neil: Have you tried to update xmms-libs package as well?

Ah, that was what I was missing!  I didn't see any mention of the xmms-libs package, and I had totally forgot that it existed.

xmms is working correctly now; thanks everyone!
Comment 13 Fedora Update System 2011-07-25 23:30:13 EDT
xmms-1.2.11-15.20071117cvs.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2011-07-25 23:47:38 EDT
xmms-1.2.11-15.20071117cvs.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.