Bug 70118 - NFS kernel module crashes on high write load
NFS kernel module crashes on high write load
Status: CLOSED DUPLICATE of bug 68026
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2002-07-30 12:03 EDT by Johan Reinalda
Modified: 2007-04-18 12:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-07-31 10:14:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Johan Reinalda 2002-07-30 12:03:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 

Description of problem:
This seemed at first similar to bugs 64921, 64984 and 65772, as fixed in 
2.4.18-5, but we are still experiencing kernel panic problems under high write 
load of the nfs server.

All clients mount with auto,noac,async,rsize

kern.log shows the following:
Jul 30 00:40:31 lifetimefs1 kernel: Assertion failure in 
ion() at commit.c:535: "buffer_jdirty(bh)"
Jul 30 00:40:31 lifetimefs1 kernel: ------------[ cut here ]------------
Jul 30 00:40:31 lifetimefs1 kernel: kernel BUG at commit.c:535!
Jul 30 00:40:31 lifetimefs1 kernel: invalid operand: 0000
Jul 30 00:40:31 lifetimefs1 kernel: autofs nfs nfsd lockd sunrpc eepro100 
ipchains usb-ohci usbcore ext3 jbd cciss

At this point all is dead, even console logins don't work and a powercycle is 
the only solution.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. High write load on the NFS server

Actual Results:  kernel panic and server is doa!

Expected Results:  NFS server keeps running :-)

Additional info:
Comment 1 Stephen Tweedie 2002-07-30 18:07:17 EDT
Is it always the same crash?

99% or more of the occurrences of this problem were fixed in 2.4.18-4smp, but I
continued to get just a few rare reports even with the fixed kernel, and found
another possible cause of the same problem since then.  That is fixed in our
internal tree and will be part of the next errata kernel.
Comment 2 Stephen Tweedie 2002-07-31 06:55:35 EDT


for a 2.4.18-7 kernel which should hopefully fix this problem.
Comment 3 Stephen Tweedie 2002-07-31 10:52:33 EDT

*** This bug has been marked as a duplicate of 68026 ***

Note You need to log in before you can comment on or make changes to this bug.