Bug 70120 - anaconda incorrectly sets the display driver of NVidia card to "vesa" instead of "nv"
anaconda incorrectly sets the display driver of NVidia card to "vesa" instead...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: hwdata (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-30 12:21 EDT by jeroen
Modified: 2014-03-16 22:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-25 17:02:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -vv output (8.29 KB, text/plain)
2002-08-15 04:28 EDT, jeroen
no flags Details
lspci -vvn output (7.36 KB, text/plain)
2002-08-15 04:29 EDT, jeroen
no flags Details
XF86Config (2.91 KB, text/plain)
2002-08-15 04:30 EDT, jeroen
no flags Details

  None (edit)
Description jeroen 2002-07-30 12:21:10 EDT
Anaconda correctly detected my graphics card (NVIDIA GeForce 4), but after
installation i noticed that it didn't set the display driver correctly (X
wouldn't start after installation & reboot).

/etc/X11/XF86Config had "vesa" set as the display driver instead of the correct
"nv" driver.

This is with Limbo beta 2
Comment 1 Michael Fulbright 2002-07-30 15:22:50 EDT
This is probably a problem with our hw database.
Comment 2 Justin M. Forbes 2002-08-01 08:46:17 EDT
It is definately in the hardware database, even with all errata installed,
configuring X will choose the Vesa driver for an Nvidia GeForce4.  Once you go
through the full configuration, choose the real resolution and color depth you
want, and skip the test.  Once it has finished, edit the /etc/X11/XF86Config-4
file and change "vesa" to "nv".  StartX and all should work well.
Comment 3 Bill Nottingham 2002-08-12 18:58:25 EDT
Which particular GeForce4 variant is this?
Comment 4 Justin M. Forbes 2002-08-12 22:50:37 EDT
On my particular instance it is a Visiontek GeForce 4 Ti 4600
Comment 5 jeroen 2002-08-13 04:09:53 EDT
I've got an Asus GeForce 4 Ti 4600.
Comment 6 Bill Nottingham 2002-08-14 00:17:31 EDT
Are you using the stock beta XFree86?
Comment 7 Mike A. Harris 2002-08-14 00:29:10 EDT
The Nvidia GeForce 4 cards are totally not supported by the "nv" driver
in XFree86 4.2.0.  Support for GeForce 4 is only available in XFree86 CVS
currently.

The GeForce 4 support was commited to XFree86 CVS trunk by Mark Vojkovich
of Nvidia:

  23. GeForce4 support (Mark Vojkovich).

The new driver code is dependant on PCI domains code in XFree86 CVS, and
a few other CVS enhancements.  I've had a look at it in the past and
considered trying to backport the minimal amount of code to enable the
GeForce 4.  It didn't look to be easily doable, but I will have another
look tonight.

No promises, but cross your fingers.  ;o)
Comment 8 Mike A. Harris 2002-08-14 03:37:20 EDT
I just went over the "nv" CVS head code, and also the initial
GeForce 4 support checkin to CVS.  The new code is far to entangled
with CVS X, and impossible to get just the required code to support
GeForce 4 without other random variables entering into the picture.

The initial checkin to CVS was not just a GeForce 4 update either,
but is littered with random changes to the driver as well.

We'll have to wait for 4.3.0 for official XFree86 support.

I'm not sure if we should configure it to use the "vga" driver (which
would really suck, and be unuseable for the most part anyway),
or just disable it entirely, or leave it as is in hopes it works
for someone out there.

I suppose disabling it entirely makes the most sense.
Comment 9 jeroen 2002-08-14 05:05:39 EDT
The only thing i know is that with the default setting (vesa driver), X wouldn't
start. Changing that from "vesa" to "nv" allowed X to start without a hitch. I
didn't run X too long before switching to the NVidia driver, but it seemed to
work fine.
Comment 10 Justin M. Forbes 2002-08-14 07:59:01 EDT
I had the same experience, the nv driver, which ships with limbo, and even the
one which ships with Red Hat 7.3 work well with the GeForce 4, no upgrades, only
Red Hat shipped code.  The only real problem here is the Xconfig tool that
Anaconda uses, and Red Hat's set up tool. The driver works, but since the config
does not know it works, it will just set it to the vesa driver.
Comment 11 Mike A. Harris 2002-08-14 21:37:14 EDT
Please attach your working XFree86 config file, X server log, and
the full output of:

lspci -vvn

and also:

lspci -vv
Comment 12 jeroen 2002-08-15 04:28:53 EDT
Created attachment 70785 [details]
lspci -vv output
Comment 13 jeroen 2002-08-15 04:29:34 EDT
Created attachment 70786 [details]
lspci -vvn output
Comment 14 jeroen 2002-08-15 04:30:26 EDT
Created attachment 70787 [details]
XF86Config
Comment 15 Bill Nottingham 2002-11-25 17:03:24 EST
This is changed in the upcoming version to use the nv driver for GeForce 4, in
combination with XFree86 4.2.99+.

Note You need to log in before you can comment on or make changes to this bug.