Bug 701265 - udev should use the ifindex for temporary name for interface renaming
udev should use the ifindex for temporary name for interface renaming
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: udev (Show other bugs)
6.1
All Linux
medium Severity high
: rc
: ---
Assigned To: Harald Hoyer
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-02 07:18 EDT by Harald Hoyer
Modified: 2011-12-06 11:27 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When udev renamed a network interface and encountered a naming conflict, it renamed the interface to "[initial name]-[desired name]". Sometimes, this name was not unique and the naming conflict persisted. This bug has been fixed, udev now uses the unique interface index for renaming, and temporary names for interfaces are now of the following format: "rename[ifindex]".
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 11:27:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 2 Harald Hoyer 2011-06-17 09:06:14 EDT
This prevents the occurrence of the temporary network interface names, when udev has to rename the network interfaces. Remember the "eth0-rename" or "eth0-eth1" temporary names?
Comment 3 Harald Hoyer 2011-06-17 09:07:11 EDT
Ah, I should add the following: These temporary names were not "unique" enough, but using the IFINDEX should be.
Comment 5 Harald Hoyer 2011-07-25 10:16:26 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
When udev renamed network interfaces and encountered a naming conflict, it renamed the interfaces to "<initial name>-<wanted name>". This name might also be not unique. So udev now uses the unique interface index for renaming and temporarily renamed interfaces now have the name "rename<ifindex>".
Comment 7 Tomas Capek 2011-08-08 05:44:28 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-When udev renamed network interfaces and encountered a naming conflict, it renamed the interfaces to "<initial name>-<wanted name>". This name might also be not unique. So udev now uses the unique interface index for renaming and temporarily renamed interfaces now have the name "rename<ifindex>".+When udev renamed a network interface and encountered a naming conflict, it renamed the interface to "[initial name]-[desired name]". Sometimes, this name was not unique and the naming conflict persisted. This bug has been fixed, udev now uses the unique interface index for renaming, and temporary names for interfaces are now of the following format: "rename[ifindex]".
Comment 9 errata-xmlrpc 2011-12-06 11:27:04 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1649.html

Note You need to log in before you can comment on or make changes to this bug.