Bug 701311 - python-fedora-0.3.22-1.fc15 breaks fedora-easy-karma
Summary: python-fedora-0.3.22-1.fc15 breaks fedora-easy-karma
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-fedora
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Toshio Ernie Kuratomi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-02 14:40 UTC by Othman Madjoudj
Modified: 2011-05-25 03:01 UTC (History)
4 users (show)

Fixed In Version: python-fedora-0.3.23-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-09 04:00:10 UTC


Attachments (Terms of Use)

Description Othman Madjoudj 2011-05-02 14:40:18 UTC
Description of problem:
After updating python-fedora to 0.3.22-1, I can't give feedback from fedora-easy-karma, I get the following error instead:

FAS Password for athmane:
Warning: Server error: ServerError(https://admin.fedoraproject.org/updates/comment, 500, Internal Server Error)
Warning: Server error: ServerError(https://admin.fedoraproject.org/updates/comment, 500, Internal Server Error)
Warning: Server error: ServerError(https://admin.fedoraproject.org/updates/comment, 500, Internal Server Error)
Warning: Comment not submitted: too many errors


Note that the web interface is working correctly, and after digging into the source code, I figured out that it's a BodhiClient issue.


Version-Release number of selected component (if applicable):

bodhi-client-0.7.10-2.fc15.noarch
python-fedora-0.3.22-1.fc15.noarch
fedora-easy-karma-0-0.11.20101123gitf70e9b6d.fc15.noarch

How reproducible:
Always

Steps to Reproduce:
1. run fedora-easy-karma
2. give feedback
3. authenticate

Filtered IRC discussion with nirik (@#fedora-admin):
<athmane> Hello all, is there a issue with bodhi, I can't give feedback from fedora-easy-karma (see: http://fpaste.org/iOk4/), but from the web interface seems to be OK ?
<athmane> AFAIK, the next outage will be at 2011-05-02 21:00 UTC
<nirik> athmane: it's working for me.
<nirik> athmane: what version of fedora-easy-karma? when did it last work?
<athmane> nirik, fedora-easy-karma-0-0.11.20101123gitf70e9b6d.fc15.noarch
<nirik> same here. ;(
<nirik> wonder if it's just one of the app servers thats failing and it's giving you that one via geoip...
<nirik> but then the web interface wouldn't work either I wouldn't think.
<athmane> nirik, also I've removed ~/.fedora, still the same issue
<nirik> athmane: anything more with --debug added?
<nirik> skvidal: just my usual monday morning pile of emails. Nothing out of the ordinary.
<athmane> nirik, just a moment, I'm testing with --debug
<athmane> nirik, nothing found with --debug, see http://fpaste.org/vN1A/
<nirik> weird.
<nirik> well, let me see if I can find anything in logs anywhere.
<athmane> nirik, seems that the session is created correctly
<athmane> nirik, I've looked at source code of f-e-k (line: 435), seems to be a issue with BodhiClient
<nirik> interesting. what bodhi-client installed?
<athmane> ninjazjb, bodhi-client-0.7.10-2.fc15.noarch, python-fedora-0.3.22-1.fc15.noarch
<athmane> ninjazjb, sorry it's for nirik 
<nirik> ah, I have an older python-fedora.
<nirik> python-fedora-0.3.21-1.fc15.noarch
<athmane> nirik, I'll try to downgrade in a moment
<athmane> nirik, downgrading python-fedora to 0.3.21-1.fc15 fixed the issue
<athmane> nirik, I get my python-fedora from updates-testing

Comment 1 Luke Macken 2011-05-02 15:15:11 UTC
This'll be fixed in the next production release of bodhi, which is going out today.

Comment 2 Fedora Update System 2011-05-04 02:10:15 UTC
python-fedora-0.3.23-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/python-fedora-0.3.23-1.fc14

Comment 3 Fedora Update System 2011-05-04 02:10:28 UTC
python-fedora-0.3.23-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/python-fedora-0.3.23-1.el5

Comment 4 Fedora Update System 2011-05-04 02:10:40 UTC
python-fedora-0.3.23-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/python-fedora-0.3.23-1.el6

Comment 5 Fedora Update System 2011-05-04 02:11:19 UTC
python-fedora-0.3.23-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/python-fedora-0.3.23-1.fc15

Comment 6 Fedora Update System 2011-05-04 02:11:32 UTC
python-fedora-0.3.23-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/python-fedora-0.3.23-1.fc13

Comment 7 Othman Madjoudj 2011-05-04 03:05:33 UTC
Seems to be fixed, fedora-easy-karma is working, I've added +1 in Bodhi.

Thank you Luke.

Comment 8 Fedora Update System 2011-05-05 04:44:31 UTC
Package python-fedora-0.3.23-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-fedora-0.3.23-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/python-fedora-0.3.23-1.fc15
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2011-05-09 03:59:58 UTC
python-fedora-0.3.23-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2011-05-20 17:54:16 UTC
python-fedora-0.3.23-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2011-05-20 17:55:58 UTC
python-fedora-0.3.23-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2011-05-25 02:32:29 UTC
python-fedora-0.3.23-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2011-05-25 03:01:12 UTC
python-fedora-0.3.23-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.