Bug 70136 - RFE: Have Anaconda handle Physical Volume Groups on raw block devices
RFE: Have Anaconda handle Physical Volume Groups on raw block devices
Status: CLOSED DEFERRED
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
limbo
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-30 13:50 EDT by Nathan G. Grennan
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-30 15:21:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan G. Grennan 2002-07-30 13:50:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020712

Description of problem:
While using Limbo beta1 I setup hdg and hgh raw as a Physical Volume Group
called vg and then setup a Logical Volume Group called data. So the combination
of hdg and hdh became /dev/vg/data. I formated it with ext3 and it became a nice
55gb filesystem. I had recompiled my kernel to have LVM support compiled in. I
also added a fstab entry for /dev/vg/data to be mounted to /mnt/data. Upon
reboot the Physical Volume Group vg was activated and /dev/vg/data was mounted.
Then Limbo beta2 came out and I backed up files to /home and rebooted to install
Limbo beta2 fresh. I didn't want to format /home or /dev/vg/data. When I got to
Disk Druid if I selected the Logical Volume Group data and then tried to hit
edit I got a error message, "Not enough physical volumes".I also was told by the
installer when entering Disk Druid that hdg and hdh weren't initialized and
asked if I wanted to initialize them, I answered no to each. If I tried to
ignore LVM and set mount points for the other partitions I got an error message
about not enough space and then the installer crashed. I tried both the
graphical and text installer multiple times and each time it crashed the same
way. Finally I shut the machine down and unplugged those drives. Then I went
booted back into anaconda and it installed just fine.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Setup a Physical Volume Group with raw drives
2. Boot off cd and start anaconda
3. Try to configure mount points for partitions in Disk Druid.

Actual Results:  Installer crashes

Expected Results:  Installer to allow the user to set mount points and continue
on with the install

Additional info:
Comment 1 Michael Fulbright 2002-07-30 15:21:34 EDT
This will have to be handled in a future release.
Comment 2 Nathan G. Grennan 2002-07-30 15:40:35 EDT
I understand this could be support in a future release, but I feel the installer
should at least let you ignore the LVM Volume Groups and not crash.
Comment 3 Jeremy Katz 2002-07-30 16:06:41 EDT
The crash about not enough space is a different bug (don't remember the bug id
offhand) that I'm just about to commit a fix for

Note You need to log in before you can comment on or make changes to this bug.