Bug 70146 - Kernel fails to compile with certain options
Kernel fails to compile with certain options
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: kernel (Show other bugs)
limbo
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-30 14:52 EDT by Nathan G. Grennan
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-30 15:54:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan G. Grennan 2002-07-30 14:52:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020712

Description of problem:
If I use kernel-source-2.4.18-7.80 and selecting the options I want. Then try to
compile the kernel modules it will gives tens of pages of error messages about
invalid syntax in lots of headers. One option when set to a module that I know
causes with is the dummy network driver. I also noticed it did this on
scsiglue.c that was a part of another option.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install kernel-source-2.4.18-7.80
2. cd /usr/src/linux-2.4.18-7.80
3. make menuconfig
4. Make sure the dummy network driver is set to compile as a module
5. Save settings
6. make dep clean modules

Actual Results:  Tons of errors

Expected Results:  Modules to compile

Additional info:
Comment 1 Miloslav Trmac 2002-07-30 15:42:11 EDT
With RH kernels, you need to start with "make mrproper" since at least 7.2
Comment 2 Nathan G. Grennan 2002-07-30 15:54:50 EDT
Tried that, didn't help.
Comment 3 Nathan G. Grennan 2002-08-07 01:18:54 EDT
make mrproper does seems to work if you use if before you do anything else.
If you compile first, get errors, and then make mrproper it seems the first make
mrproper doesn't do a complete job and so a second make mrproper is required.

So always make mrproper before doing anything else.

Note You need to log in before you can comment on or make changes to this bug.