Bug 701496 - An Error Occurred: /admin/languagemanager.xhtml @49,56 sortBy="#{language.uLocale.variant}": Property 'uLocale' not found on type net.openl10n.flies.model.HLocale
An Error Occurred: /admin/languagemanager.xhtml @49,56 sortBy="#{language.uLo...
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.3-alpha-1
All Linux
low Severity low
: ---
: ---
Assigned To: Runa Bhattacharjee
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-02 21:53 EDT by Kenichi Takemura
Modified: 2014-08-04 18:03 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-21 01:34:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
heaps of stack traces (20.47 KB, application/x-gzip)
2011-05-05 02:26 EDT, Kenichi Takemura
no flags Details
sort sort sort sort sort! (285.84 KB, image/png)
2011-05-05 02:26 EDT, Kenichi Takemura
no flags Details

  None (edit)
Description Kenichi Takemura 2011-05-02 21:53:22 EDT
Description of problem:

Sorting by 'Variant' in the language list produces an error

Version-Release number of selected component (if applicable):
Zanata version 1.3-alpha-1 (20110330-1649). 

How reproducible:
always

Steps to Reproduce:
1. Logon Zanata using administrative account
2. Manage Language
3. Add New Langueage
4. Sort by 'Variant'
  
Actual results:
Sorting by 'Variant' in the language list produces an error

Expected results:
Sorted.

Additional info:
Comment 1 hding 2011-05-02 22:34:50 EDT
There is no 'Variant' in the language list any more in the trunk.
Comment 2 Kenichi Takemura 2011-05-02 23:44:07 EDT
Hi
Can you tell me where is newer build to be ready for QE than below which I am currently testing?

http://hudson.englab.bne.redhat.com/hudson/view/Tag%20Build/job/flies-tag-build-war/lastBuild/
Comment 3 Sean Flanigan 2011-05-03 01:07:35 EDT
Nothing yet, but I plan to tag and build Zanata 1.3-alpha-2 today.  I'll let you know.
Comment 4 Kenichi Takemura 2011-05-05 02:25:42 EDT
I tested on Zanata version 1.3-alpha-2 (20110504-1839). 

No Variant and seems sorting by Language and Name is working but uninterrupted click,click,click on the sort icon produces heaps of stack traces(attached server.log) and zanata ends up with Unexpected error(attached screen)
Comment 5 Kenichi Takemura 2011-05-05 02:26:20 EDT
Created attachment 496986 [details]
heaps of stack traces
Comment 6 Kenichi Takemura 2011-05-05 02:26:41 EDT
Created attachment 496987 [details]
sort sort sort sort sort!
Comment 7 Sean Flanigan 2011-09-07 00:33:35 EDT
Assigning to Scrum product owner for prioritisation.
Comment 8 Alex Eng 2012-06-19 23:18:35 EDT
Kenichi Takemura, 

Is the problem still occur in recent release?
Comment 9 Kenichi Takemura 2012-06-20 19:32:03 EDT
(In reply to comment #8)
> Kenichi Takemura, 
> 
> Is the problem still occur in recent release?

Hi Alex

I do not have any Zanata instance now.
Could you give me a test instance with administrative account so that I can test again? This bug was opened year agao so not sure there still be around.
Comment 11 Kenichi Takemura 2012-06-20 21:16:42 EDT
Hi Alex

I presume the UI feature has changed since this bug was filed.
I do not see 'Variant' column in language management view.
I am not albe to re-produce this bug any more, please feel free to close. 

Thanks!
Comment 12 Alex Eng 2012-06-21 01:34:50 EDT
Bug no longer exists due to UI changes.

Note You need to log in before you can comment on or make changes to this bug.