This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 701614 - Gnome Mime type associations to applications are broken if exo package (Xfce) is installed
Gnome Mime type associations to applications are broken if exo package (Xfce)...
Status: CLOSED DUPLICATE of bug 674321
Product: Fedora
Classification: Fedora
Component: gvfs (Show other bugs)
15
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-03 07:11 EDT by Michal Ambroz
Modified: 2015-03-03 18:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-03 07:34:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot.png (12.82 KB, image/png)
2011-05-03 07:11 EDT, Michal Ambroz
no flags Details

  None (edit)
Description Michal Ambroz 2011-05-03 07:11:31 EDT
Created attachment 496489 [details]
screenshot.png

Description of problem:
There is some race condition for Gnome Desktop Environment triggered by installing package of exo file manager (part of Xfce desktop environment), which causes Gnome desktop environment to process MIME associations in a wrong way. 

#xdg-mime query filetype screenshot.png
image/png

#xdg-mime query default image/png
gnome-eog.desktop

So you would guess that eog will be executed to process a file, but instead the nautilus is executed and ends with attached error.



Version-Release number of selected component (if applicable):
gvfs-1.8.1-1.fc15.i686
exo-0.6.0-5.fc15.i686
nautilus-3.0.1-1.fc15.i686


How reproducible:
100%

Steps to Reproduce:
1. Have installed Gnome and Xfce desktop environment
2. Run GNOME session (Please note I am using gnome and not Xfce)
3. Trigger mime action from commandline:
#xdg-open /tmp/screenshot.png

  
Actual results:
#xdg-open /tmp/screenshot.png
triggers
#gvfs-open /tmp/screenshot.png 
which triggers
#exo-open --launch FileManager /tmp/screenshot.png 
which triggers
#nautilus /tmp/screenshot.png
and ends with error message:
Could not display "/tmp/screenshot.png". The location is not a folder.


Expected results:
In my opinion when having Gnome session the behaviour should not be affected by having installed any other desktop environment. These things should be independent. Running gnome - it should take gnome mime type settiongs, running Xfce it shuold take Xfce mime type settings. 

Additional info:
Comment 1 Michal Ambroz 2011-05-03 07:20:08 EDT
I forgot to mention that after uninstalling the exo package things work as expected in Gnome:
#sudo rpm -e exo --nodeps
#xdg-open /tmp/screenshot.png 
triggers
#gvfs-open /tmp/screenshot.png
which opens file using /usr/share/applications/gnome-eog.desktop as expected

Problem is that obviously this will break the Xfce functionality on the other hand.

Best regards
Michal Ambroz
Comment 2 Tomáš Bžatek 2011-05-03 07:34:25 EDT

*** This bug has been marked as a duplicate of bug 674321 ***

Note You need to log in before you can comment on or make changes to this bug.